SaabCentral Forums banner

boost power loss

  1. Erratic Boost Issues

    NG900 & OG9-3 Workshop
    Just a little bit of background: About a year ago, I got a BBS stage 1 tune flashed onto my ECU on my '00 9-3 SE. I also have the R hose to the EVAP system pulled off the BCV and plugged. I have been running like this for a while. The problem is that occasionally under WOT, it will build a...
  2. Boost Leak Question

    C900 Workshop
    Soooooo that 20PSI I was reaching with the '89 has now become 15PSI Under boost right around 10PSI I start hearing a whistle from the turbo area and it seems to hold ok till 15 were it then bounces off 15 and drops back down to around approx 10-12 Based on searching I should check the charge...
  3. red top fuel injectors 431 and AMM resistor size

    C900 Performance, Mods & Tuning
    I pulled some Bosch 431 injectors from a NG 900 at the wrecking yard. So this post is about figuring out how to make sure the car doesn't run too rich or too lean by modifying the Air Mass Meter with a resistor in the output line (orange wire). I have a Swedish Dynamics modified APC (got it 16...
  4. P2100 Code Saab 9-3 2001 2.2 Diesel

    NG900 & OG9-3 Workshop
    Hi All, I have recently bought a Saab 9-3 2001 2.2 Diesel. The car idles rough but not sure if this is just how they are being a diesel. I recently serviced the car and also decided to clean the MAF, Air intake pipe and clean the EGR valve. When I took off the Air intake pipe I noticed...
  5. Boost leak

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hey guys I have a 2003 93 limear 2.0t I recently got a cel and it said something about a random misfire and a boost leak and the guy at auto zone looked it up and said that it was my upper intercooler hose? Not sure where that is and wether or not that's the problem. Any guesses? Ps. I have a...
  6. 9-5 Aero 2001 stage 3 BSR lacking power

    9-5 Performance, Mods & Tuning
    Hi guys. I have done the "Bolt mod" to the evap system without any luck. Tried changing the BOV to a Forge with yellow spring - still no luck. The built-in boost gauge never goes in the red. I cant remember if it did at the start of my stage 3 tuning, but it has lost a lot of power since...
Top