SaabCentral Forums banner

boost loss

  1. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Recently I lost boost suddenly, once after being at high rpm and once while just cruising at low rpm. The first and second times i just replaced the front boost controller and the problem was solved. The first time with a used one and the second time with a brand new one from Sweden. The second...
  2. 9-5 Workshop
    Hello all, I recently became the excited new owner of a sleek 2008 Saab 9-5 in Titan Grey, an amazing upgrade from the 2004 9-5 Linear I was sporting before. Unfortunately, taking ownership of this car has caused me to join the "9-5 slow acceleration/low boost" club. Here's the issue: The A/C...
  3. C900 Workshop
    Soooooo that 20PSI I was reaching with the '89 has now become 15PSI Under boost right around 10PSI I start hearing a whistle from the turbo area and it seems to hold ok till 15 were it then bounces off 15 and drops back down to around approx 10-12 Based on searching I should check the charge...
  4. NG900 & OG9-3 Workshop
    I have 01 9-3 with a stage 3 tune. Recently I've noticed that peak boost pressure is dropping off after the engine gets hot. I used to be able to consistently hit 15+ psi now I can only do so in about the first 10 minutes of driving, afterward it maxes out at about 10 psi. I have replaced the...
  5. 9-5 Workshop
    Greetings, I know there are several topics about power loss here, however I did not find answers that would solve my particular issue. The car starts linearily losing boost after ~30-40 minutes drive, no matter, motorway or city. During another 30 minutes of drive the boost linearily/slowly...
  6. 9-5 Workshop
    Hi everyone, first post. Been using this site for years now and have saved literally 1000's of dollars. Thanks so much. 2001 Saab 9-5 2.3T with 225k miles, pretty certain the engine was replaced at 120k (that's what the previous owner told me). The car was given to me for free, so was pretty...
  7. NG900 & OG9-3 Workshop
    Ok so I just picked up a 1999 9-3 base model (T5) and it's acting oddly when the engine is cold. I didn't notice at first (the temp gauge doesn't work) until I hooked up my Kiwi and found out that it only acts up when the engine is below operating temperature. If you get on it too hard and hit...
  8. NG900 & OG9-3 Performance, Mods & Tuning
    1995 900 SE Turbo I decided to remove the mid pipe of exhaust just mess around and see how it sounded(not bad). After doing so and putting it back on i felt a big loss in the amount of boost im getting, but just to make it clear it was around the time I did this, I dont think it...
Top