SaabCentral Forums banner

acceleration delay

  1. Sluggish and no power when warm.

    9-5 Workshop
    Ok so i just bought a 2006 9-5 aero. i love this car and when it is running good it is a blast to drive. the issue that i am having is that after it has warmed up the throttle response it almost non existant. i have done the following things to try and resolve the issue. 1. New NGK OE plugs...
  2. Performance question

    9-5 Workshop
    Hi guys, a question about my 2003 9-5 linear. It's been running great all winter and I don't think the following is a serious issue, but I'm curious about whether it's normal or indicative of something that needs a cleaning or other maintenance. When I'm coasting with my foot completely off...
  3. 01 9-5 bad idle and engine shut off?

    9-5 Workshop
    I was just driving my car back to my house and the first thing I noticed was when accelerating the car would buck, from accelerating to nothing all while my foot was pressing the pedal. Then at stop the idle would drop then go back to normal then drop again. This culminated with my car shutting...
  4. Hey new member here! Having issues with my 2003 93 Arc.

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    So first off thank you for taking a look, I have been having this issue for the last few weeks and i am starting to get worried. When I am driving and am in 3,4,5 and 6 gear when I try accelerating hard my car starts sputtering as if it was going to misfire so I quickly let off the gas, but when...
  5. 1999 Saab 9-5 problem.

    9-5 Workshop
    I've been looking at a 1999 Saab 9-5 for a little over a week. I like saabs and everything about them, I haven't yet purchased it because it has a problem and they haven't ordered the part to fix it. They said it drives good but once the car warms up it won't pull.. They also said it doesn't...
  6. Cylinder Misfires

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hey guys, I have a 2003 9-3 2.0T Vector, 6-speed manual and I had been having some issues with acceleration. Initially I thought that it was something wrong with the turbo, because as I accelerate the car will start to stutter and acceleration is significantly slowed. This will happen in 2-6...
  7. Engine Hesitation/Poor Acceleration/Oxygen Sensor Code

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I have a 2003 vector with an 04 2.0t engine in it. I originally had some rough idle issues that went away. But they did set off a check engine light which spits back a code for a bad upstream oxygen sensor (too lean i believe). I am experiencing poor acceleration, sub-par gas mileage, and this...
  8. turbo/boost/coilpack issue?

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I was driving down the road, about 5 minutes into my drive today and my car went crazy. I have a 04 9-3 Arc 2.0T automatic w/100K miles. I guess I should start by mentioning that a week or so ago, I noticed a burning smell after driving the car for awhile. I have a 40 minute one-way...
  9. Car won't accelerate

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I seem to be having issue with acceleration that is getting worse 2007 93 2.0T manual, 6-sd, anniversary ed. 60k had the car for 2 months It used to be that the accelerator wasn't responding right away, almost as if there was a half second delay before the car would get-up and go (oh, and only...
Top