Turbo X stuttering ?? - Page 2 - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > 9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines > 9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines

9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines 9-3 SportSedan, Convertible ('04+)/Combi & 9-3X, 2003 - 2012 Technical & Repair

SaabCentral.com is the premier Saab All Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #21  
Old 20th March 2012
xxxxxxxwickyianr1
Guest
 
Posts: n/a
Default

Hi davo defo coils had my tx a month had it tuned from the day I picked it up it didn't like it took tune off still hesitating so after new plugs and coils alls fine now got my coils from cesuk Wrexham 45 plus vat easy to do front 3 a doddle back 3 a pain once done easy watch for the britle pipes though.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #22  
Old 20th March 2012
Cosmicflash Cosmicflash is offline
Saab on the Brain!
 
Join Date: Jun 2003                                                
Location: Chicago
My Saabs: '09 9-3 SS Aero XWD
Posts: 5,873
Default

Quote:
Originally Posted by 1slo_aero View Post
like everyone else says its the coils, this ecm has the worst misfire detection ever. i have a vtune stage 0 and i've gone threw 3 coils so far right now on a 4th. it only misfires on wot in the upper rpm or mid rpm band when it dont down shift, it feels like a shutter or fishbite. the worst part is the ecm will not throw a code until you basically keep in the throttle when it misfires and it begins to shutter real bad.

on a side note

dear bosch

get a with the misfire detection everyone else's ecm's dont seem to have this problem

sincerely your pissed off lp9 owners everywere
Isn't that the truth I've been saying this for years. Maybe the newer Bosch ME 9.xx is a bit better. I really haven't had to find out.

I remember the on my T8 and little misfire or fuel cap being off for more than 30 seconds would trigger the CEL.
I can drive around all day with fuel cap off of a V6 and no CEL
__________________
03' SS Linear Cosmic Blue, 109k mi., gone
06' SC Aero Auto Fusion Blue, BSR tuned, 94k gone.
09' SS Aero XWD Auto
Carbon Gray, Black Premium Leather, VTuned, 30% tint.
Reply With Quote Quick reply to this message
  #23  
Old 20th March 2012
Davo14 Davo14 is offline
Senior Member
 
Join Date: May 2009                                                
Location: United Kingdom
My Saabs: 93 Turbo X manual - Maptun Stage 1
Posts: 210
Default

many thanks

your coils from wrexham appear cheap. Robert Bowett (Saab dealer) in Leeds quoted me 1200 to replace all 6 coils !!!!

Can you send me details of the coils you bought please?

Cheers
Reply With Quote Quick reply to this message
 
  #24  
Old 20th March 2012
xxxxxxxwickyianr1
Guest
 
Posts: n/a
Default

Pm sent davo I will find the number in the morning I work nights ok
Reply With Quote Quick reply to this message
  #25  
Old 20th March 2012
ylee coyote ylee coyote is offline
Saab Crazy
 
Join Date: Sep 2002                                                
Location: Trossachs
My Saabs: Turbo X ,500 hp 9000,900 T16s
Posts: 593
Default

rock auto ships to uk

6 coils cost me about 230 delivered with vat paid
got them in a week
great service ....

and they are Bosch in a different box
__________________
9000 aero stg 7 266k miles 500 hp six speed !
9000 cs 2.0 stage 6 350 hp track slag
900 t16s classic 184k
9-3ss 2009 turboX sportwagon 69,000 miles
Reply With Quote Quick reply to this message
  #26  
Old 20th March 2012
Davo14 Davo14 is offline
Senior Member
 
Join Date: May 2009                                                
Location: United Kingdom
My Saabs: 93 Turbo X manual - Maptun Stage 1
Posts: 210
Default

thanks chaps - that's a great help
Reply With Quote Quick reply to this message
  #27  
Old 19th December 2013
Bo$$'s Avatar
Bo$$ Bo$$ is offline
Active Member
 
Join Date: Dec 2011                                                
Location: Wayne, NJ
My Saabs: 2005 and 2008 Saab 9-3 2.0t, 2008 TurboX
Posts: 42
Default Crazy turn of events

So I bought my TX back In Sept. Have had it checked out a few times I'm very thorough with my cars. Everytime came back in excellent shape. With the exception of the brakes (front) and the creaking noise from what the dealer think is a loose backing plate. Had the Brakes done ASAP OEM no problem at all. Car has been running strong, having a great time with it.

Bought it with 29,980 on 9/16/13 and today it has 34,900 on it.

About 3 weeks ago the car started shuttering when I started it up in park. This was after a 90 minute drive and I had stopped to pick someone up and when I started this occurred. It shuttered so bad that it in fact stalled out and shut off. Scared the living **** out of me. I thought maybe it was bad batch of gas I always use 93 Octane. Filled it up with 93 and heard a minor shudder maybe 1 or 2 more times that day. Did a lot of starting up and turning the car off was all over the place. Next day never heard the noise again for 3 weeks until Monday Night. Made a shutter pretty significant for about a minute. I started driving at the stop signing or any stopping no more shuttering. Happened again yesterday and today both minor but noticeable on start up (cold or warm engine temp). I live in NJ been in the 30s this week. Was 60 when it happened the first time.

NOW FOR THE FUN.

Today went to the car wash to get all that disgusting salt off the car. Was waiting in line all of a sudden the CHECK ENGINE light pops on. My heart SINKS. I'm thinking WTF!

So it gets better. In the car wash (car wash makes you get out and walk thru the inside) the car in front of me dies. The have to push it out and jumper pack it. Then my car DIES and they have to jumper pack it. The car behind mine dies and the same thing happens. I'm thinking what the hell is going on. And these guys are great guys never an issue with them they detail ferrari's and expensive benz all the time (upper middle class area). Anyhow they jump my car I drive around. Get home then have someone else come over and listen to my car and he's like yeah the engine sounds like its struggling (In park) it still drives fine.

Couple of notes

MY MPG has dropped with the last 2 batches of gas from AVG of 20 to 15 MPG. Was snowing and snow out there past 2 weeks but still.

The dealer I bought the car from was Curry Chevy. They wrote my Oil Sticker for 3,000 miles. 32,980. That sounds like conventional oil, something makes me wonder if they put in Synthetic. I usually go 5,500-6,000 between synthetic changes. So I'm about 1,000 miles out. However if they put in convention not only is it overdue it's screwing up the engine BIG TIME. Not sure if it would run with conventional which makes me think it is synthetic.


Have an appointment with Saab tomorrow morning. Plan of taking car of the backing plate with whatever work needs to be done as a result of this.

What should I expect? I fear the worst!
Reply With Quote Quick reply to this message
  #28  
Old 22nd December 2013
Kurtisl8 Kurtisl8 is offline
Senior Member
 
Join Date: Jan 2012                                                
Location: Connecticut
My Saabs: 2008 Turbo X 6-Sp V-Tune Stage 0
Posts: 156
Default

Quote:
Originally Posted by Bo$$ View Post
So I bought my TX back In Sept. Have had it checked out a few times I'm very thorough with my cars. Everytime came back in excellent shape. With the exception of the brakes (front) and the creaking noise from what the dealer think is a loose backing plate. Had the Brakes done ASAP OEM no problem at all. Car has been running strong, having a great time with it.

Bought it with 29,980 on 9/16/13 and today it has 34,900 on it.

About 3 weeks ago the car started shuttering when I started it up in park. This was after a 90 minute drive and I had stopped to pick someone up and when I started this occurred. It shuttered so bad that it in fact stalled out and shut off. Scared the living **** out of me. I thought maybe it was bad batch of gas I always use 93 Octane. Filled it up with 93 and heard a minor shudder maybe 1 or 2 more times that day. Did a lot of starting up and turning the car off was all over the place. Next day never heard the noise again for 3 weeks until Monday Night. Made a shutter pretty significant for about a minute. I started driving at the stop signing or any stopping no more shuttering. Happened again yesterday and today both minor but noticeable on start up (cold or warm engine temp). I live in NJ been in the 30s this week. Was 60 when it happened the first time.

NOW FOR THE FUN.

Today went to the car wash to get all that disgusting salt off the car. Was waiting in line all of a sudden the CHECK ENGINE light pops on. My heart SINKS. I'm thinking WTF!

So it gets better. In the car wash (car wash makes you get out and walk thru the inside) the car in front of me dies. The have to push it out and jumper pack it. Then my car DIES and they have to jumper pack it. The car behind mine dies and the same thing happens. I'm thinking what the hell is going on. And these guys are great guys never an issue with them they detail ferrari's and expensive benz all the time (upper middle class area). Anyhow they jump my car I drive around. Get home then have someone else come over and listen to my car and he's like yeah the engine sounds like its struggling (In park) it still drives fine.

Couple of notes

MY MPG has dropped with the last 2 batches of gas from AVG of 20 to 15 MPG. Was snowing and snow out there past 2 weeks but still.

The dealer I bought the car from was Curry Chevy. They wrote my Oil Sticker for 3,000 miles. 32,980. That sounds like conventional oil, something makes me wonder if they put in Synthetic. I usually go 5,500-6,000 between synthetic changes. So I'm about 1,000 miles out. However if they put in convention not only is it overdue it's screwing up the engine BIG TIME. Not sure if it would run with conventional which makes me think it is synthetic.


Have an appointment with Saab tomorrow morning. Plan of taking car of the backing plate with whatever work needs to be done as a result of this.

What should I expect? I fear the worst!
I know coils are a big problem with this engine. I've had multiple cold start problems with my car that I have never been able to get fixed (check my post history). Seems like you are having a lot of the classic problems with this car!

As far as your MPG, I WISH I had yours. I usually average about 17mpg, so 250 miles on a tank, if I'm lucky :-(
Reply With Quote Quick reply to this message
  #29  
Old 22nd December 2013
TunnanXWD TunnanXWD is offline
Saab on the Brain!
 
Join Date: Jan 2010                                                
Location: WestCentral NooYersey
My Saabs: 280-XWD Aero & a 2.0 XWD
Posts: 7,637
Default

xxxxxxxxxxwickyinar1, how do you have a 2009 Turbo X if they only made them in 2008.

You mean an Aero XWD or a 2.0 XWD perhaps?
__________________
Semper ubi ubi inn captut tuum
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Reply With Quote Quick reply to this message
  #30  
Old 22nd December 2013
Kurtisl8 Kurtisl8 is offline
Senior Member
 
Join Date: Jan 2012                                                
Location: Connecticut
My Saabs: 2008 Turbo X 6-Sp V-Tune Stage 0
Posts: 156
Default

Quote:
Originally Posted by TunnanXWD View Post
xxxxxxxxxxwickyinar1, how do you have a 2009 Turbo X if they only made them in 2008.

You mean an Aero XWD or a 2.0 XWD perhaps?
I think he may be technically right. I remember reading some left over inventory were actually sold as "2009" model year.
Reply With Quote Quick reply to this message
  #31  
Old 22nd December 2013
Cosmicflash Cosmicflash is offline
Saab on the Brain!
 
Join Date: Jun 2003                                                
Location: Chicago
My Saabs: '09 9-3 SS Aero XWD
Posts: 5,873
Default

Quote:
Originally Posted by Kurtisl8 View Post
I know coils are a big problem with this engine. I've had multiple cold start problems with my car that I have never been able to get fixed (check my post history). Seems like you are having a lot of the classic problems with this car!

As far as your MPG, I WISH I had yours. I usually average about 17mpg, so 250 miles on a tank, if I'm lucky :-(
You the original owner Kurtis?
__________________
03' SS Linear Cosmic Blue, 109k mi., gone
06' SC Aero Auto Fusion Blue, BSR tuned, 94k gone.
09' SS Aero XWD Auto
Carbon Gray, Black Premium Leather, VTuned, 30% tint.
Reply With Quote Quick reply to this message
  #32  
Old 22nd December 2013
TunnanXWD TunnanXWD is offline
Saab on the Brain!
 
Join Date: Jan 2010                                                
Location: WestCentral NooYersey
My Saabs: 280-XWD Aero & a 2.0 XWD
Posts: 7,637
Default

Hmmmm, that doesn't sound right especially for the US anyway. We did have a number of TX's here that went unsold but it was a limited run of 600 and they were all 2008's.

That means that like the Shelby Cobras (perhaps), Saab did not complete the build of 600 for Europe and the UK and still had the certificates to build "x number of cars during that period". But that's a long shot because 9-3 production kept on unlike Shelby that stopped till those certs popped up years later. Technically, in 2000 (something), you could buy a Cobra that was titled as a 1967. Shelby donated all of the proceeds to the American Heart Association.
__________________
Semper ubi ubi inn captut tuum
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Reply With Quote Quick reply to this message
  #33  
Old 22nd December 2013
Kurtisl8 Kurtisl8 is offline
Senior Member
 
Join Date: Jan 2012                                                
Location: Connecticut
My Saabs: 2008 Turbo X 6-Sp V-Tune Stage 0
Posts: 156
Default

Quote:
Originally Posted by Cosmicflash View Post
You the original owner Kurtis?
No I bought the car from a dealer after it's original owner's lease was up.
Reply With Quote Quick reply to this message
  #34  
Old 27th December 2013
leviivey leviivey is offline
Active Member
 
Join Date: Apr 2013                                                
Location: rapid city sd
My Saabs: 08 9-3 Aero
Posts: 63
Default

i just gapped my plugs down to about 32 which is a tiny gap also went with colder plugs have an extra 12 coils just in case but i believe the coils dont always arc enough and the spark is blown out sometimes under full boost gapping them in should almost certainly cure your problem.
Reply With Quote Quick reply to this message
  #35  
Old 27th December 2013
Martin_9-5t's Avatar
Martin_9-5t Martin_9-5t is offline
Saab Lunatic
 
Join Date: Jun 2004                                                
Location: South Wales U.K
My Saabs: 93 Turbo X JZW
Posts: 1,442
Default

Quote:
Originally Posted by TunnanXWD View Post
xxxxxxxxxxwickyinar1, how do you have a 2009 Turbo X if they only made them in 2008.

You mean an Aero XWD or a 2.0 XWD perhaps?
Nope he means turbo x.

It's the same with mine. Technically it was made in 2008 but not registered or on the road until 2009.
In my case it was late June 2009. Doesn't make any difference to spec etc but it does make a difference to the value.
__________________
UK distributor for JZW tuning
Reply With Quote Quick reply to this message
  #36  
Old 27th December 2013
TunnanXWD TunnanXWD is offline
Saab on the Brain!
 
Join Date: Jan 2010                                                
Location: WestCentral NooYersey
My Saabs: 280-XWD Aero & a 2.0 XWD
Posts: 7,637
Default

Exactly, the car is a 2008 (look on the door plate for manufacturing date), but in the UK it's registered as a 2009.

Here in the US that would be registered and titled as a 2008. I guess you have a title in UK as well as registration .. the title is the permanent ownership document issued in the state, for me New Jersey from the first dealer and then changed to the name of a new owner when sold. Here the registration is an annual document issued with your plate numbers on it. In the US they would both read 2008 on the registration and 2008 on the title.

That has to cause a lot of confusion when ordering parts or do you have to know your cars serial number (VIN), for each item you order?
__________________
Semper ubi ubi inn captut tuum
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Reply With Quote Quick reply to this message
  #37  
Old 28th December 2013
Martin_9-5t's Avatar
Martin_9-5t Martin_9-5t is offline
Saab Lunatic
 
Join Date: Jun 2004                                                
Location: South Wales U.K
My Saabs: 93 Turbo X JZW
Posts: 1,442
Default

It's different here.

We have 1 registration document, this contains all car details and current owner details. On this document it shows as a 2009 car. The registration document, called a V5 stays with the car, if the car changes owner the document is sent away and new one issued with new owner details on.

No problems with parts, the supplier will just as for the reg number and all the car details come up on the system.

Hope that makes sense
__________________
UK distributor for JZW tuning
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo Redlining/Stuttering After Being Replaced whyteb 9-5 Workshop 0 3rd April 2011 09:27 PM
Turbo Stuttering mthydro NG900 & OG9-3 Workshop 1 21st April 2010 03:35 PM
BSR Stuttering J4CKO 9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines 38 6th January 2008 02:51 PM
900SE Turbo - Engine stuttering on start Kel NG900 & OG9-3 Workshop 20 17th July 2007 08:02 PM
'95 900SE Turbo engine stuttering raftel NG900 & OG9-3 Workshop 3 7th June 2007 05:12 PM


All times are GMT -4. The time now is 04:20 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.