Blower off on hot start/ fine on cold start - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

Notices

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab All Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 3 Days Ago
andtheHawks andtheHawks is offline
Active Member
 
Join Date: Nov 2016                                                
Location: Baltimore MD
My Saabs: '96 9k Aero; '04 9-5 SC; ex'06 9-3 SC
Posts: 53
Default Blower off on hot start/ fine on cold start

If I start the car cold, my ACC blower fan works perfectly normal and great. (calling for A/C currently in the summer) I can change fan speed to my hearts content, until the car is turned off.

If I start the car hot, the blower fan will not engage until I have driven say 30 mph for 3-4 mins, or say 45 mph for 2-3 mins.

A real world example: start car after work (car in sunny parking lot) full blower capabilities, im feeling good. Stop to get gas half way home about 20 mins later, and on the hot start, NO blower at all..... sit in traffic for five minutes, nothing but getting sweaty. Get out of traffic hit a road i can do 30-45 on and about two mins the blower kick on.

So seems to be engine bay temp related.

I do not know or have any observations of say driving for over an hour at a time at highway speeds on a hot day....(so dont know if engine bay could then get hot enough to shut it off again while driving, which i have yet to experience.

I have had bad blower motors before on other cars and they usually just die, or are intermittent possessed style.

I have had bad blower fan regulators, or resistors, on other cars, but I always have the very definitive symptom- blower works on high speed, but not any other lower speeds.

Anyone have this experience before?


again, works great when cold start and when driving at enough speed to give some sort of cooling (i am assuming) to the engine bay.

thanks all

Last edited by andtheHawks; 3 Days Ago at 06:56 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 3 Days Ago
EdT EdT is offline
Saab on the Brain!
 
Join Date: Oct 2011                                                
Location: Toronto
My Saabs: 1997 900S Coupé, 2003 9-5 Linear Wagon
Posts: 7,386
Default

When it's working, the fan speeds are as per ACC settings? If so, I'd suspect brushes are gone on the blower. I had the same intermittent now it doesn't work, now it works, during the cold weather.
Reply With Quote Quick reply to this message
  #3  
Old 3 Days Ago
andtheHawks andtheHawks is offline
Active Member
 
Join Date: Nov 2016                                                
Location: Baltimore MD
My Saabs: '96 9k Aero; '04 9-5 SC; ex'06 9-3 SC
Posts: 53
Default

Yes, when blower is working (blows) I can control the fan settings and the pictogram rising graph corresponds to the blower output.
Furthermore when observing fan voltage with Tech2 (in the DICE settings I believe) I can watch the voltage rise to 12-range when i increase the fan speed at the ACc panel, and decrease (down to like 4-5v) when i decrease the fan setting at the ACC panel (manually).

My first suspicion was blower motor, even before I found this temp related pattern, so i ordered one up... but then today finally figuring out the intermittent had a pattern, I got worried that maybe it could be the resistor.

I was just in the footwells doing a bleand door shaft fix and had enough back and neck strain for the week!

thanks ed. Unless anyone else has thoughts, I will probably try to swap the motor out tomorrow...before a long drive to NC on Saturday.......

Reply With Quote Quick reply to this message
 
  #4  
Old 2 Days Ago
EdT EdT is offline
Saab on the Brain!
 
Join Date: Oct 2011                                                
Location: Toronto
My Saabs: 1997 900S Coupé, 2003 9-5 Linear Wagon
Posts: 7,386
Default

The shop did mine--they had a good blower off a 9-5 they just parted out. One thing they said, if the blower isn't reinstalled just right, it can make noise. I assume that's the squirrel cage rubbing on something.


I have the old blower, and one of these days I will investigate swapping out the brushes on it. It worked fine otherwise, wasn't even noisy in the depths of cold winter weather.
Reply With Quote Quick reply to this message
  #5  
Old 2 Days Ago
andtheHawks andtheHawks is offline
Active Member
 
Join Date: Nov 2016                                                
Location: Baltimore MD
My Saabs: '96 9k Aero; '04 9-5 SC; ex'06 9-3 SC
Posts: 53
Default

discussion with my indy, leads him to fully suspect the regulator. SO I am going to hold off and bring to him next week.

Will report resolution then. They have had exact same symptoms before, resolved by the regulator.

fine with me, ive had enough DIY last few weeks!
Reply With Quote Quick reply to this message
  #6  
Old 2 Days Ago
Doug's Avatar
Doug Doug is offline
Saab Crazy
 
Join Date: Apr 2003                                                
Location: Hove Actually, UK.
My Saabs: '97 9000 Aero. '04 9-5 Aero estate
Posts: 566
Default

Just to be pedantic, the fan speed controller does its thing by pulse width modulation, not resistance variation.

The loom goes from one footwell, through the bulkhead, past the fan and back through the other bulkhead (if it’s pre- 2006). Difficult to remove, so I spliced on a replacement “lump” to the old loom. Post change-over units are the same as pre. Only the loom arrangement is different, and the wire colours are the same.
Reply With Quote Quick reply to this message
  #7  
Old 2 Days Ago
bob3000's Avatar
bob3000 bob3000 is offline
Saab Lunatic
 
Join Date: Jul 2010                                                
Location: Ottawa
My Saabs: 2000 9-5 AERO 5spd man MPS STG2
Posts: 3,434
Default

Quote:
Originally Posted by andtheHawks View Post
They have had exact same symptoms before, resolved by the regulator.
I've had the same symptoms on a couple of 9-5s and it was never the regulator just worn motor brushes.

A good test is the next time the fan isn't working properly bang your fist on the dashboard between the windshield and the center speaker and see if the fan speed changes, if it does it's not the regulator.
.
Reply With Quote Quick reply to this message
  #8  
Old 2 Days Ago
andtheHawks andtheHawks is offline
Active Member
 
Join Date: Nov 2016                                                
Location: Baltimore MD
My Saabs: '96 9k Aero; '04 9-5 SC; ex'06 9-3 SC
Posts: 53
Default

Glad you were pedantic (not that you were)
Learned something new. Pulse width modulation....interesting stuff. I had no idea! (regulator, not resistor)

Have definitely tried the dash board bang. Does not work.

Resolution next week, being thoughtful of use and keeping it as much to a cold start situation wont be to onerous.

could be worse, hopefully it doesnt get worse, but stays predictable.
Sort of a bad bet, assuming a predictable pattern of something that is obviously failing....
but not a big risk

ill keep posted resolution (wont be until next friday)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:53 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.