(HELP) 1986 900s automatic does not go into gear - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab C900, 1979-1993 & '94 Convertible (C=classic) > C900 Workshop

Notices

C900 Workshop Classic 900 (1979-1993 & '94 Convertible) Technical Forum.

SaabCentral.com is the premier Saab All Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 5 Days Ago
JonathanSAAB JonathanSAAB is offline
New Member
 
Join Date: Jul 2019                                                
Posts: 2
Exclamation (HELP) 1986 900s automatic does not go into gear

I have a 1986 900 s with an automatic transmission and when I was driving yesterday the engine suddenly stalled during normal acceleration. I pulled over and started the car and it idled just fine, but it would not engage into any gears. I got it towed back to my house and it continues to start and idle fine but will not engage into gear. When I move the gear selector lever there is no noise or change in revs, however the car will role when in neutral and it remains stationary when in park. Please help me to figure out what the problem may be.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 5 Days Ago
jvanabra jvanabra is online now
Saab Lunatic
 
Join Date: Feb 2004                                                
Location: California
My Saabs: LOTS. :)
Posts: 3,420
Default

Not to be obvious, but have you checked the fluid level?
Reply With Quote Quick reply to this message
  #3  
Old 5 Days Ago
JonathanSAAB JonathanSAAB is offline
New Member
 
Join Date: Jul 2019                                                
Posts: 2
Default

yes the fluid level is correct.
Reply With Quote Quick reply to this message
 
  #4  
Old 5 Days Ago
jvanabra jvanabra is online now
Saab Lunatic
 
Join Date: Feb 2004                                                
Location: California
My Saabs: LOTS. :)
Posts: 3,420
Default

It could be a band out of adjustment, or it could be a deeper internal problem, or the transmission has given up. From the sound of your post, it seems like the best option is have a professional shop take a look at it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
900, automatic transmission

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:16 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.