2009 9-5 fuel pump sender problem - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab All Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 3 Weeks Ago
Goldman Goldman is offline
Active Member
 
Join Date: May 2018                                                
Posts: 50
Default 2009 9-5 fuel pump sender problem

ok

I put a new walbro pump assembly in the tank, it was new but the fuel sending unit was broken (the clip that holds the float arm was broken) so I installed an aftermarket fuel sender which i unsoldered the original wires from the original unit and soldered them onto the aftermarket unit. Now the fuel gauge in the dash shows full when the tank is empty, is it just a matter of swapping the 2 wires to get it to work properly? I will check first that the float is not stuck. let me know
Dan
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 3 Weeks Ago
andybisnut andybisnut is offline
Saab Lunatic
 
Join Date: Jun 2013                                                
Location: Minnesota
My Saabs: 2006 9-5 SportCombi 2.3T
Posts: 1,990
Garage
Default

Quote:
Originally Posted by Goldman View Post
ok

I put a new walbro pump assembly in the tank, it was new but the fuel sending unit was broken (the clip that holds the float arm was broken) so I installed an aftermarket fuel sender which i unsoldered the original wires from the original unit and soldered them onto the aftermarket unit. Now the fuel gauge in the dash shows full when the tank is empty, is it just a matter of swapping the 2 wires to get it to work properly? I will check first that the float is not stuck. let me know
Dan
Did you by chance purchase it on eBay? I was looking at that one.
Reply With Quote Quick reply to this message
  #3  
Old 3 Weeks Ago
Doug's Avatar
Doug Doug is offline
Saab Crazy
 
Join Date: Apr 2003                                                
Location: Hove Actually, UK.
My Saabs: '97 9000 Aero. '04 9-5 Aero estate
Posts: 655
Default

Does the rheostat on the aftermarket sender send the current/voltage the ECU can understand? Even the Saab ones aren't all the same, i.e. different ohms for the max and min positions.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:15 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.