Dead 9-3 - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-3 SportSedan, Cabrio ('04+), Combi & 9-3X, 2003-2012 > 9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines

Notices

9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines 9-3 SportSedan, Convertible ('04+)/Combi & 9-3X, 2003 - 2012 Technical & Repair

SaabCentral.com is the premier Saab All Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st May 2019
Shandit Shandit is offline
Senior Member
 
Join Date: Aug 2009                                                
Location: Toronto, Ontario, Canada
My Saabs: Saab 9-3 Aero (2006) all black
Posts: 132
Default Dead 9-3

Over the last few months, the "not so trusty" 9-3 has experience electrical problems.

- starting - periodically it would not. No starter click. Removed and cleaned the key control (sorry dont know the name). It helped a bit.
- had communication errors with the steering column as per the OBD2
- ABS error

Finally I was driving along, all the warning lights in the dash lit up, the speedo dropped to zero - but it kept driving just fine.

When I stopped, it stubbornly refused to start - completely dead.

Tried the OBD2 - no readings at all.
It really seems like an electrical / communication issue.

Q1 - The next thought was to use the Tech2. I have the dongle connection, but no idea how to use the software. Is there a link for basic how-to of Tech2?

Q2 - any other ideas of basic stuff to look at?


Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 1st May 2019
Mort Mort is offline
SaabNut!
 
Join Date: Mar 2018                                                
Location: Auckland, New Zealand
My Saabs: 00 9-3 Aero (B205R)
Posts: 269
Garage
Default

Could it be a fuse or relay that's got a bad or dirty connection?
Reply With Quote Quick reply to this message
  #3  
Old 1st May 2019
Nordic-Machine's Avatar
Nordic-Machine Nordic-Machine is offline
SaabNut!
 
Join Date: Dec 2016                                                
Location: Singapore / Haifa
My Saabs: 2008 9-3 SS Linear
Posts: 345
Default

It could be faulty ABS control unit.
Reply With Quote Quick reply to this message
 
  #4  
Old 1st May 2019
Shandit Shandit is offline
Senior Member
 
Join Date: Aug 2009                                                
Location: Toronto, Ontario, Canada
My Saabs: Saab 9-3 Aero (2006) all black
Posts: 132
Default

Quick update. I cleaned all fuses and grounds I could get my hands on. Boosted it off my other car. After a few tries, it actually fired up!!! Surprise.

Check the error codes and got:
U0212 Lost Communication With Steering Column Control Module

My previous suspicion was the Ignition Switch Module.
Would that generate such an error?

More importantly: is there a reference on how to use Tech 2 on a laptop, so I can diagnose this better?

Last edited by Shandit; 1st May 2019 at 04:02 PM.
Reply With Quote Quick reply to this message
  #5  
Old 1st May 2019
Abarth's Avatar
Abarth Abarth is offline
Saab Lunatic
 
Join Date: Dec 2006                                                
Location: SoCal
My Saabs: na
Posts: 1,187
Default

Had the same problem a few weeks ago. It was a combination of the CIM, and the ABS module. You need to have a Tech II to interface everything back and to reprogram your keys. MY07 Aero was laid up for 2 weeks since there are no ABS modules in the USA, so we had to send mine out for a rebuild. Don't by one off eBay, since if the modules are not correctly 'divorced' from the doner car you can't TechII it to mate with yours.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message
  #6  
Old 2nd May 2019
mcgyvah's Avatar
mcgyvah mcgyvah is offline
Senior Member
 
Join Date: Feb 2015                                                
Location: New South Wales, Australia
My Saabs: '04 9-3 Vector (Marilyn) "Aero spec"
Posts: 205
Garage
Default

How is the battery condition. Bad battery can cause similiar probs.


Quote:
Originally Posted by Abarth View Post
...Don't by one off eBay, since if the modules are not correctly 'divorced' from the doner car you can't TechII it to mate with yours.

Shouldn't need to divorce anything. Just have to add it with tech 2.
Reply With Quote Quick reply to this message
  #7  
Old 2nd May 2019
Shandit Shandit is offline
Senior Member
 
Join Date: Aug 2009                                                
Location: Toronto, Ontario, Canada
My Saabs: Saab 9-3 Aero (2006) all black
Posts: 132
Default

Quote:
Originally Posted by Shandit View Post
Quick update. I cleaned all fuses and grounds I could get my hands on. Boosted it off my other car. After a few tries, it actually fired up!!! Surprise.

Check the error codes and got:
U0212 Lost Communication With Steering Column Control Module

My previous suspicion was the Ignition Switch Module.
Would that generate such an error?

More importantly: is there a reference on how to use Tech 2 on a laptop, so I can diagnose this better?
Replaced the battery.
Took the old one to the refirb shop. Guy said it looked like "chocolate" after only 2 years. Guess being close to the turbo might be the issue.

With the new battery, it starts, somewhat reliably.

OBD2 says "No Link"
Dash shows ABS, brake - so guess ABS issues are next....

Above, I saw that ABS issues can prevent starting, which is kind of a dumb design. Cars have driven just fine for 100 years without ABS....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3 dead fuel pumps vijon NG900 & OG9-3 Workshop 12 11th April 2011 05:55 PM
Dead battery...i hope? Schulzyk 9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines 4 17th February 2011 09:56 AM
GS vs Ultimate Pedals Dead Pedal Warren9-3 9-3 Sedan, Convertible ('04+)/Combi & 9-3X Workshop - ALL Engines 16 2nd February 2011 09:56 AM
Anyone have a dead DI cassette? mphtower 9-5 Workshop 5 22nd May 2005 08:20 AM
Stupid jump lead question Mark Harrison C900 Workshop 10 17th December 2001 12:44 PM


All times are GMT -4. The time now is 05:57 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.