SaabCentral Forums - View Single Post - 85 900 Turbo swap, No Start, Injectors not getting power. Properly Stumped
View Single Post
  #1  
Old 13th June 2019
trau trau is offline
Junior Member
 
Join Date: Jun 2016                                                
Location: Colorado
My Saabs: 1983 900 Turbo
Posts: 9
Default 85 900 Turbo swap, No Start, Injectors not getting power. Properly Stumped

Hello Team. I'm hoping some of you can help me out with this, it's been a long troubleshooting road that led to this post and I'm stumped - I apologize ahead of time for the long post, but I want to make clear what troubleshooting steps I've taken.

Mine is a project car in which I just finished swapping an '85 16V Turbo engine into the chassis of an '83 8V turbo. The car is put back together and cranks but does not start. I have ruled out air and spark because it coughs with starter fluid. I installed an in-line fuel pressure sensor as part of the swap, and am showing ~36 PSI, but there are some electrical indications that the injectors are not receiving the proper signal, and there is no smell of gas in the cylinders after removing a spark plug after cranking for a reasonable amount of time. Ipso facto: there's pressurized fuel in the fuel rail (so mechanically a good fuel system up to the injectors), but no fuel getting to the cylinders.

It's an LH 2.2 system. I followed the troubleshooting steps in Bentley as well as this Townsend page (which more or less parallels the Bentley):
http://townsendimports.com/Web/engin.../nostart22.htm

I also used the pin references from this page:
http://www.saabnet.com/tsn/faq/lhoverview.html

And my problem seems identical to this individual, but it looks like the problem never got resolved on this thread:
https://www.saabcentral.com/forums/n...newthread&f=14

Here's what I've ruled out based on troubleshooting:
- The fuel pump and system relays are undoubtedly working properly (and are the correct relays I think, but I'll double check that they match one another).
- Ignition pulse signal is there - I get 2-3 VAC at the ECU harness pins 1 and 25 when the engine is cranked, which is per the Bentley/Townsend.
- There's fuel pressure in the rail based on the pressure gauge, so everything upstream of the injectors is presumably working properly.
- Every other electrical test the Bentley has comes up good, with the exception of one; at the ECU harness, there should be continuity between pin 12 (Throttle position switch, wide open) and ground with the throttle wide open. This is not the case, which I assume is maybe a bad switch or connection, but I didn't really investigate because it didn't seem relevant (throttle shouldn't need to get wide open for starting, so I put that one on the back burner - should I investigate this further...?)

Here's some common suggestions that I also ruled out:
- Fuses - pulled every single one, all good
- Boost overpressure switch - just jumped it and have left it that way to rule it out for troubleshooting purposes.
- Grounds - I tested the grounds at the ECU harness (i.e. I measured voltage between pin 18 (battery voltage from the fuse box) and pins 5, 18, and 25 (the grounds at the harness). They all showed good battery voltage (~12.4); additionally, I checked for ground at all the grounding points I could find, and they all seemed good. I know grounds can be finnicky though, so I'm not entirely ruling that one out.
- Disintegrating wiring harness - I have found it disintegrating in certain places, but have replaced all the wires that are falling apart and have checked 70% of the wiring between the ECU and the fuel injectors. I will take it all apart soon just to be sure, but it looks good.

Here's the bad parts that stand out:
- Bently/Townsend says that when the engine is cranked, voltage across the injector harness connector should be 1 V at room temp. It shows 0.000 volts. The next step is to check for battery voltage between the blue/red pin and ground with the ignition on. I get about 3.4 V with a fully charged battery, which I can't make sense of.
- The last step of the Townsend troubleshooting page is to ground ECU pin 17 and see if there's battery voltage and the blue/red wires to the injectors, which there is. I'm not exactly sure what pin 21 does (saabnet page says "main relay operating circuit output). I assume grounding it mimics the ECU sending a grounding signal to the injectors, i.e. opening them. Since this test came up positive, Townsend concludes that it's a bad ECU.

Having felt like I thoroughly troubleshot (did most things twice or more, tried to be very methodical), I ordered a reportedly good used ECU from the interwebs, plugged it in, tried to start aaaaand, nothing (i.e. still no start, still no fuel fumes in the cylinders). To me, this rules out the ECU as the problem as well. So I'm out of ideas.


If you've stuck with me this far, I commend and thank you. In summary: engine won't start, but seems to be getting good air and spark. There's pressurized fuel in the fuel rail, but no fuel getting into the cylinders - this plus the erroneous electrical tests at the injector harnesses most likely indicates an electrical problem with the ECU and/or the wiring harness. Wiring harness seems good, ECU(s) seem fine, and the injectors themselves show the right resistance, plus all of them aren't injecting fuel, so they would all have to be kaput.

If anybody has any ideas, I will be forever indebted to you. Thank you ahead of time!!
Reply With Quote