Check Engin Light -code P1181 - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th October 2006
acastillo178 acastillo178 is offline
Junior Member
 
Join Date: Sep 2006                                                
Location: collingswood, nj
My Saabs: 1999 saab 9-5 silver
Posts: 27
Default Check Engin Light -code P1181

could anybody help me with this code p1181, i dont know what it is and how can i fix it?.thank you.

Last edited by acastillo178; 29th October 2006 at 09:55 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 29th October 2006
Kermit's Avatar
Kermit Kermit is offline
Saabista
 
Join Date: Sep 2004                                                
Location: London UK
My Saabs: 04 9-5 Vector 2.2Tid
Posts: 11,009
Default

Here ya go....

Reply With Quote Quick reply to this message
  #3  
Old 29th October 2006
acastillo178 acastillo178 is offline
Junior Member
 
Join Date: Sep 2006                                                
Location: collingswood, nj
My Saabs: 1999 saab 9-5 silver
Posts: 27
Default

thanks for the help.i think is better for me to take it to a mechanic.do you know any mechanics in south jersey that my be able to help me.
Reply With Quote Quick reply to this message
  #4  
Old 29th October 2006
VTwagon VTwagon is offline
SaabNut!
 
Join Date: Aug 2006                                                
Location: Vermont
My Saabs: 2001 95 se v6 2003 95 aero, manual
Posts: 335
Default

Clean the MAF first. If that doesn't work maybe time to replace either it or the O2 sensor. I suppose you could also check for leaks before buying any sensors.
Reply With Quote Quick reply to this message
  #5  
Old 29th October 2006
SectorNine50's Avatar
SectorNine50 SectorNine50 is offline
Saab Lunatic
 
Join Date: Sep 2005                                                
Location: Oregon, USA
My Saabs: 2000 9-5 Aero 5-Speed
Posts: 4,845
Default

Quote:
Originally Posted by acastillo178
thanks for the help.i think is better for me to take it to a mechanic.do you know any mechanics in south jersey that my be able to help me.
You aren't running an open element intake with an oiled filter by chance are you?
Reply With Quote Quick reply to this message
  #6  
Old 29th October 2006
acastillo178 acastillo178 is offline
Junior Member
 
Join Date: Sep 2006                                                
Location: collingswood, nj
My Saabs: 1999 saab 9-5 silver
Posts: 27
Default

everything is stock

Last edited by acastillo178; 29th October 2006 at 10:50 PM.
Reply With Quote Quick reply to this message
  #7  
Old 4th February 2008
Nor_Cal_Driver's Avatar
Nor_Cal_Driver Nor_Cal_Driver is offline
Senior Member
 
Join Date: Nov 2005                                                
Location: Northern California
My Saabs: 98 900 SE
Posts: 154
Default

Is this the same for lpt or hpt 2.3l mills? My lpt has done this 3 times now . . .gonna check the filter and intake system first, then spray the maf/p sensor with some cleaner then replace the 02's after that????
__________________
98 900 SE Half Hot | |01 Audi A4 Quattro Turbo w/ Chips and Salsa |
86 900 EMS, 01 9-5 Wagon 2.3 lpt: missed
Reply With Quote Quick reply to this message
  #8  
Old 5th February 2008
Al's Red Wagon's Avatar
Al's Red Wagon Al's Red Wagon is offline
Saab Lunatic
 
Join Date: Apr 2007                                                
Location: Newburgh, NY, USA
My Saabs: 1999, Cayenne Red 9-5, 2.3 Wagon
Posts: 2,846
Default Air leak?

I ran into this problem on my other car.

Seems that I had a leak in my intake pipe (soft plastic) between the MAF and the Throttle Body. Check the gaiter connected to the MAF and the various hoses that run off from the throttle body to see that that they are connected properly and they are not leaking.

Last edited by Al's Red Wagon; 5th February 2008 at 04:29 AM.
Reply With Quote Quick reply to this message
  #9  
Old 6th February 2008
Nor_Cal_Driver's Avatar
Nor_Cal_Driver Nor_Cal_Driver is offline
Senior Member
 
Join Date: Nov 2005                                                
Location: Northern California
My Saabs: 98 900 SE
Posts: 154
Default

Quote:
Originally Posted by Al's Red Wagon
I ran into this problem on my other car.

Seems that I had a leak in my intake pipe (soft plastic) between the MAF and the Throttle Body. Check the gaiter connected to the MAF and the various hoses that run off from the throttle body to see that that they are connected properly and they are not leaking.
Roger Wilco, thanks for the help./
__________________
98 900 SE Half Hot | |01 Audi A4 Quattro Turbo w/ Chips and Salsa |
86 900 EMS, 01 9-5 Wagon 2.3 lpt: missed
Reply With Quote Quick reply to this message
  #10  
Old 22nd February 2008
Nor_Cal_Driver's Avatar
Nor_Cal_Driver Nor_Cal_Driver is offline
Senior Member
 
Join Date: Nov 2005                                                
Location: Northern California
My Saabs: 98 900 SE
Posts: 154
Default

I said F it today and am dropping the 9-5 off for my tech to diagnose, this car is starting to frustrate me into a V70 . . .let's keep our fingers crossed.

Damn the P1181!
__________________
98 900 SE Half Hot | |01 Audi A4 Quattro Turbo w/ Chips and Salsa |
86 900 EMS, 01 9-5 Wagon 2.3 lpt: missed
Reply With Quote Quick reply to this message
  #11  
Old 20th September 2009
shub's Avatar
shub shub is offline
SaabNut!
 
Join Date: Oct 2004                                                
Location: USA: Portland, ME
My Saabs: '99 9-3 SE Auto @ 292K mi
Posts: 304
Default

2002 LPT is pulling this code off the tech 2 as well. Car is experiencing noticeable lapse in power over the past few months. I have owned the car for about 18 months. Very hesitant accelerations, even for an automatic low pressure turbo. Last time it was in the mechanic, the hose connecting to the MAF was tightened. Check engine light remained off for about two weeks after that. Power remained weak. I want to clean my MAF, but sadly I don't even know what it looks like! Is there a picture guide anywhere?

I changed the spark plugs two days ago, and the CEL came back on the next day- not sure if it's related, definitely feels that way. It was the first time I ever changed spark plugs in a car. I used a gap gauge at 1.1mm and a torque wrench set to 28 Nm.

I had a partner cold start the car while I looked under the hood- I can hear a whispy, breathy sound coming from the lower left region of the engine bay.

I also spotted oil bubbling out of the manifold on the front of the engine, the pipe furthest to the right- it looks like my manifold is missing a bolt right there incidentally... but why would oil come out of that region, isn't the manifold on the front an exhaust manifold? It stopped oozing oil there after the car warmed up to operating temperature. I don't hear or see any exhaust fumes escaping from where the oil came out though.

Valve cover gasket was replaced last year. It does not seem to be leaking. Should I replace air filter and fuel filter? Car has about 250,000 miles on it. Previous owner drove 75,000 miles in one year with no service records noted, so there may be some neglected routine maintenance items.
Reply With Quote Quick reply to this message
  #12  
Old 25th October 2009
ccrawford57's Avatar
ccrawford57 ccrawford57 is offline
Active Member
 
Join Date: Jan 2009                                                
Location: new jersey
My Saabs: 2002 SAAB 9-5 Aero Wagon
Posts: 43
Default

Best mechanic... Tom at Foreign Cars of Monmouth.... Near Red Bank NJ
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:51 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.