Engine Hesitation/Skip During Acceleration - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th October 2006
gemlam
Guest
 
Posts: n/a
Default Engine Hesitation/Skip During Acceleration

My 2001 2.3 lpt 9-5 has had an infrequent, but annoying problem that I would like to fix. I bought the car 6 months ago, and it has 50,000 miles on the odometer. The problem is a brief engine hesitation or skip during low to moderate acceleration (mostly with the turbo needle at the white to yellow transition on the gage). This condition would happen once or twice a month, this summer, but had not occurred for sevral months until yesterday. After a 120 mile drive on the highway, it happened 3 times while driving in city traffic (when accelerating lightly around 20 to 30 mph). Seemed like heavier pedal pressure would eliminate the hesitation. My return trip on the highway (120 miles) was a perfect ride, no problems. This hesitation has only occurred once at highway speed (on cruise control, 70 mph, when encountering a light uphill grade, car recovers in 1/2 sec and continues to run great).
The only other problem I have had (probably unrelated) is cold start in New England. I have seen several posts similar to my problem. On the initial crank, the engine starts, runs rough for 1 to 2 sec, and stalls. The second crank results in a normal start (no roughness or other problems).
Thanks for your help. Go Pats!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 8th October 2006
TurboBlix's Avatar
TurboBlix TurboBlix is offline
Saab Lunatic
 
Join Date: Apr 2006                                                
Location: Disco Volante
My Saabs: '09 WRX
Posts: 2,427
Default

i had the same engine crank issues as you do currently. the mechanic replaced the direct ignition cassette and the crankshaft position sensor and it now starts fine. the check engine light came up for the direct ignition cassette. when i had the code pulled it was P1300. if you're not getting the check engine light, it might just be a CPS problem.

if your 9-5 is from 2000- on, your direct ignition cassette might be replaced free by a dealership b/c of a recall. i have a 1999, so, no dice.

here's a link to a thread i started about my DIC problem and its resolution, you might find it helpful: http://www.saabcentral.com/forums/sh...ad.php?t=83502
__________________
+ 4-wheel photos

Last edited by TurboBlix; 8th October 2006 at 10:43 AM. Reason: added thread link
Reply With Quote Quick reply to this message
  #3  
Old 8th October 2006
gemlam
Guest
 
Posts: n/a
Default

Thanks Blixahaha, I'll call the local dealer to see if I am covered by the recall for the DIC, and get to work on the CPS.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:52 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.