No Main Beam light - SaabCentral Forums
* site search:  
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum

Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > Saab 9-5 Workshop
Saab 9-5 Workshop Saab 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th September 2006
circuitman's Avatar
circuitman circuitman is offline
Active Member
 
Join Date: Dec 2005                                                
Location: West Sussex UK
My Saabs: 9-5 2.3 lpt SE & 9-3 2.0T SE 'Vert
Posts: 94
Default No Main Beam light

SAABMeisters,

I have got no main beam/high beam head lighting up on the nearside (left). I have swapped out the bulbs, they are OK, swapped out the relay for the AC one which is the same, and still no joy (AC does work) and swapped over the 15A fuses for left and right main beams.

I also note that the little blue light on the dash doesnt light up, but the right beam works fine even on flash-to-pass mode.

Any bright (sorry!) ideas?

Circuitman
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 26th September 2006
Kermit's Avatar
Kermit Kermit is offline
Saabista
 
Join Date: Sep 2004                                                
Location: London UK
My Saabs: 04 9-5 Vector 2.2Tid
Posts: 10,999
Default

Try cleaning the contacts on the orange relay under the bonnet, also turn main beams on and wiggle the same relay to see if the light comes back on. The relay contacts can dry out over time and cause these lighting issues.
Reply With Quote Quick reply to this message
  #3  
Old 27th September 2006
circuitman's Avatar
circuitman circuitman is offline
Active Member
 
Join Date: Dec 2005                                                
Location: West Sussex UK
My Saabs: 9-5 2.3 lpt SE & 9-3 2.0T SE 'Vert
Posts: 94
Default

Thanks for the reply Kermit.


Hmmmm.... Orange relay? mine are all grey!

I have tapped, wiggled, cajoled and downright shouted at them to no avail. Nothing lights up on the one side. I had a look at a schematic diagram here:

http://www.mitt-eget.com/saab/inform...tml#schematics

Which was a switch main beam lights mod, but also shows the original wiring.

I'm curious as the Glödtrådsvakt = "light bulb guard" shows connections out to the bulbs both dipped and main beams. Could this be the culprit? Where is it? I need to check for sparks before and after this unit to confirm.

Circuitman
Reply With Quote Quick reply to this message
  #4  
Old 27th September 2006
Kermit's Avatar
Kermit Kermit is offline
Saabista
 
Join Date: Sep 2004                                                
Location: London UK
My Saabs: 04 9-5 Vector 2.2Tid
Posts: 10,999
Default

Hmmmm, do you not have one of these?

Reply With Quote Quick reply to this message
  #5  
Old 28th September 2006
circuitman's Avatar
circuitman circuitman is offline
Active Member
 
Join Date: Dec 2005                                                
Location: West Sussex UK
My Saabs: 9-5 2.3 lpt SE & 9-3 2.0T SE 'Vert
Posts: 94
Default

"I'm curious as the Glödtrådsvakt = "light bulb guard" shows connections out to the bulbs both dipped and main beams. Could this be the culprit? Where is it? I need to check for sparks before and after this unit to confirm."

That'll be the orange one then! Aha! (Lamp control) - will get the prising device (flat bladed screwdriver) into it later on today and check it out. I was busy looking at the specific high beam realy (thats the one top left in your pic).
Cheers!

Circuitman
Reply With Quote Quick reply to this message
  #6  
Old 28th September 2006
circuitman's Avatar
circuitman circuitman is offline
Active Member
 
Join Date: Dec 2005                                                
Location: West Sussex UK
My Saabs: 9-5 2.3 lpt SE & 9-3 2.0T SE 'Vert
Posts: 94
Default

Good call on the orange relay Kermit!


Opened it up and found the soldered terminals to the pin-outs had a couple of dry joints on them. Quick resolder later (lead free of course!) and bright lights.

Was curious to note that it's all solid state in there too!
Reply With Quote Quick reply to this message
  #7  
Old 28th September 2006
Kermit's Avatar
Kermit Kermit is offline
Saabista
 
Join Date: Sep 2004                                                
Location: London UK
My Saabs: 04 9-5 Vector 2.2Tid
Posts: 10,999
Default

Strike one up to the frog.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.