Engine coolant fluid - I think I'm loosing it :-) - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9000 > 9000 Workshop

9000 Workshop 9000 (1985-1998) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th March 2003
greenphotos's Avatar
greenphotos greenphotos is offline
Saab Crazy
 
Join Date: Feb 2003                                                
Location: Flying in my Vector in Basing-St'oke - 2002 9-5 Vector
Posts: 927
Default Engine coolant fluid - I think I'm loosing it :-)

My 9000 Aero seems to be loosing engine coolant at a suprising rate, I only re-filled it up about a week ago and it is already down at the min' mark and the on-dash indicator is lit.

Is there a common pipe fault with the system or do you think is it something more serious?

Someone please help as fluid is getting an unwanted expense!

:-?? :-??
Mark
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 19th March 2003
arjo arjo is offline
Junior Member
 
Join Date: Feb 2003                                                
Location: holland
Posts: 14
Default

Hi Mark : several posibilities.
Head failure :gasket between shortblock and head defect.
Is there any smoke out of the pipe ? 2 A small leak in one
of the hoses( Mostly at the place of a motor connection.
Then you 'll lose fluid when the system is under presure.
You should invest these things.
regards Arjo
Reply With Quote Quick reply to this message
  #3  
Old 19th March 2003
greenphotos's Avatar
greenphotos greenphotos is offline
Saab Crazy
 
Join Date: Feb 2003                                                
Location: Flying in my Vector in Basing-St'oke - 2002 9-5 Vector
Posts: 927
Default thanks

Thanks, I'll check them out when it is lite. i get the feeling it may be the pipes, when i listen hard (and the engine hasn't cooled totally, there is a very faint hissing sound coming from the top of the expansion tank. I reckon this might be it.

Mark
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:03 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.