turbo problem - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9000 > 9000 Workshop

9000 Workshop 9000 (1985-1998) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th August 2005
SAABidji SAABidji is offline
Junior Member
 
Join Date: Jul 2005                                                
Location: France
My Saabs: 9000 2.0L Turbo 16v M90
Posts: 18
Default turbo problem

Okay. My 9000 was having trouble on hard acceleration in 5th gear. The APC/turbo gauge would go into the red (slightly) and the car would hesitate and wouldn't go faster than 140km/h. So I changed most everything I could to get rid of that problem: I bought and installed a new APC solenoid, a new dumpvalve, changed the DI-cassette and plugs... each of which made the things a tad better but wouldn't solve the problem completely. Now this morning, I decided to try and change the 4mm hoses for new ones... those looked okay to me, but you never now...
So I bought the new hoses, installed them in place of the old ones and... everything was fine! The car would accelerate normally in every gear, no problem. It would just stall a little bit at idle, but nothing to (apparently) worry about. Too good to be true...
Now I was on my way home, like 15 minutes ago. Went out of the highway. Stopped at the stop sign. First gear, no problem. Second gear, rev to about 3000... BANG! engine stopped, Check Engine Light on and all. I turn the key again, engine starts. I accelerate gently... and soon as the turbo gauge approaches the yellow zone, the engine hickups and stops, with lots of black smoke coming out of the exhaust pipe.
What the heck just happened? I sure hope it's not the turbo... any idea?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 5th August 2005
SAABidji SAABidji is offline
Junior Member
 
Join Date: Jul 2005                                                
Location: France
My Saabs: 9000 2.0L Turbo 16v M90
Posts: 18
Default

update: unplugged the airmass meter and now the engine runs... only the turbo won't really start but I guessit's normal. could a faulty airmass meter cause that kind of issues?
Reply With Quote Quick reply to this message
  #3  
Old 6th August 2005
boxman's Avatar
boxman boxman is offline
Saab on the Brain!
 
Join Date: Nov 2003                                                
Location: south west_UK
My Saabs: 9-3 SS Aero TTiD + 9-3 SV Aero
Posts: 7,970
Default

have a good look around the intercooler pipes to make sure you havent blown off a pipe, it may be on just enough to work under vacumm but once the turbo boosts blows off the pipe again
Reply With Quote Quick reply to this message
  #4  
Old 6th September 2005
SAABidji SAABidji is offline
Junior Member
 
Join Date: Jul 2005                                                
Location: France
My Saabs: 9000 2.0L Turbo 16v M90
Posts: 18
Default

Yep, that was the problem indeed. Many thanks. (I was on vacation, couldn't reply earlier)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:37 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.