Need some help on a very annoying idle/drivability problem - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab C900, 1979-1993 & '94 Convertible (C=classic) > C900 Workshop

C900 Workshop Classic 900 (1979-1993 & '94 Convertible) Technical Forum.

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st April 2005
Dacolino Dacolino is offline
Junior Member
 
Join Date: Jan 2005                                                
Location: Hawthorne, NJ
My Saabs: 1987 Saab 900 16vT
Posts: 24
Default Need some help on a very annoying idle/drivability problem

Hi i have a 87 16v Turbo...I will start out with the idle problem...When i first start the car, it almost stalls and pretty much everytime i come to a stop the same thing happens. When im idling the idle hunts up and down between 1000 and 700 usiually...sometime when i first start the car it goes from almost 700 to 1500. Along with this i have drivability issues in which sometimes the car has no power even when the turbo spools and boost is there. for instance mainly when i take let out the clutch in 1st, if I let it out a little quick the car falls on its face and will have no power at all, and when you hit boost the gauge goes up normal range but still you alot less power than normal, and then sometimes out of nowhere it goes away and resumes full power. On top of this i have a problem with my fuel and temp gauges...the fuel gauge seems fine when i fill up and for the next 20 miles, but after that it kinda does its own thing...sometimes it reads empty sometimes 1/2....depends on how it feels i guess, and my temp gauge is way off, it goes up very quickly and stays 3/4 way up or more sometimes...i verified that it is not running too hot. Since i bought the car ive replaced the turbo, coolant temp semsor, fan switch, thermostat, expansion tank cap, and recently replace the 02 sensor as i ran many test and found that the 02 was not responding properly. so i replaced it, and also found wiring faults in the heater cicuit and replaced some wiring and put a new blade style inline fuse in. im thinking it might be the AIC valve...although it buzzes i dont think its working properly...also i cleaned and oiled it...ive also verified the tps is correct, the amm flashes like its supposed to, everything seemed to check out fine according to the book...I also reset the screw in the AMM to the specified value that the bentley said. All the grounds seem to be fine too.

Please help me!!
Thanks,
Colin
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 21st April 2005
Matthew's Avatar
Matthew Matthew is offline
Saab Mad
 
Join Date: Dec 2001                                                
Location: Gloucestershire, UK
My Saabs: 900 S Aero Turbo, 9-5 Aero
Posts: 14,069
Default

As for the hunting idle, have you read this?
http://www.saabcentral.com/techhelp/...g_problems.php
Reply With Quote Quick reply to this message
  #3  
Old 25th April 2005
Dacolino Dacolino is offline
Junior Member
 
Join Date: Jan 2005                                                
Location: Hawthorne, NJ
My Saabs: 1987 Saab 900 16vT
Posts: 24
Default

Still diagnosing...thanks for those that have helped so far..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:32 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.