is it the bov - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab C900, 1979-1993 & '94 Convertible (C=classic) > C900 Workshop

C900 Workshop Classic 900 (1979-1993 & '94 Convertible) Technical Forum.

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th May 2004
alan forsyth alan forsyth is offline
Saab Crazy
 
Join Date: Oct 2003                                                
Location: wishaw scotland
Posts: 722
Default is it the bov

when the boost starts to build i can hear a lot of hissing is it the bov ,no leaks anywhere ,all new silicone hosing .idle is fine as well :-??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 25th May 2004
craigdeluxe's Avatar
craigdeluxe craigdeluxe is offline
SaabNut!
 
Join Date: Sep 2003                                                
Location: glasgow
My Saabs: 1990 t16s 1992 900se lpt
Posts: 286
Default

I'll have your new valve next week alan. So if its that no need to worry.
Reply With Quote Quick reply to this message
  #3  
Old 25th May 2004
alan forsyth alan forsyth is offline
Saab Crazy
 
Join Date: Oct 2003                                                
Location: wishaw scotland
Posts: 722
Default

good man craig cheers mate
Reply With Quote Quick reply to this message
  #4  
Old 26th May 2004
alan forsyth alan forsyth is offline
Saab Crazy
 
Join Date: Oct 2003                                                
Location: wishaw scotland
Posts: 722
Default

got a kevlar diaphragm ordered for the atmos trying to seal the old one for now to see if it is the bov.i'm blowing the *** out of these things this weather
Reply With Quote Quick reply to this message
  #5  
Old 26th May 2004
alan forsyth alan forsyth is offline
Saab Crazy
 
Join Date: Oct 2003                                                
Location: wishaw scotland
Posts: 722
Default

on closer inspection it was the 2 inside bolts for the turbo that was causing the grief.anyway got the atmos running again will give it a blast tomorow
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.