ABS / Wheel Speed Sensor? - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab NG900, 1994-1998 and OG9-3, 1999-2002 & '03 Convertible (NG=new gen/OG=old gen) > NG900 & OG9-3 Workshop

NG900 & OG9-3 Workshop NG900 (1994 to 1998) & OG9-3 (1999-2002) & '03 Convertible Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th May 2004
swdmus's Avatar
swdmus swdmus is offline
Senior Member
 
Join Date: Jun 2003                                                
Location: Central New York
My Saabs: 1991 900s and a 1994 900SE Turbo
Posts: 197
Default ABS / Wheel Speed Sensor?

So I hear he ABS and the wheel speed sensor are the same thing. Im guessing that only one of the ABS sensors is also the wheel speed sensor? and Im also guessing that the wheel speed sensor is on the front of the car not the back because when the tires spin in the winter the speedometer goes up? now if im all right here Im wondering if the speed sensor is on the right or left wheel?

Can someone help me find the correct abs sensor for the wheel speed?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 4th May 2004
bkrell's Avatar
bkrell bkrell is offline
Saab on the Brain!
 
Join Date: Sep 2003                                                
Location: Louisiana
My Saabs: gone: '01 9-5 2.3t, 1997 900 SE turbo
Posts: 9,423
Default

The info I have just give the procedure as:

Ensure fuses No. 17 and 18 are okay. Raise and support
vehicle. Turn ignition on. Rotate wheels by hand. ABS control module
should send a pulsed A/C speed signal to terminal No. 7 (Gray/Green
wire) of main instrument display No. 1, and terminal No. 5
(Orange/White wire) of main instrument display No. 2. If pulsed signal
is not present, check for an open or short.

Of course, this will require you to pull the cable to the instrument panel!

It also mentioned speed sensors on the input and output safts of the transmission. Obviously, though, your problem is tied to ABS. The sensors are pretty simple devices. You should visibly be able to tell if something is wrong with them.
Reply With Quote Quick reply to this message
  #3  
Old 4th May 2004
bkrell's Avatar
bkrell bkrell is offline
Saab on the Brain!
 
Join Date: Sep 2003                                                
Location: Louisiana
My Saabs: gone: '01 9-5 2.3t, 1997 900 SE turbo
Posts: 9,423
Default

Oooops! Forgot this part!!!


ABS ECM receives wheel speed information from left front
wheel sensor at terminal No. 7, and is grounded at terminal No. 6.
Information from right front wheel sensor is received at terminal No.
5, and is grounded at terminal No. 3.
Left rear wheel sensor information is sent to ABS ECM
terminal No. 9, and is grounded at terminal No. 8. Right rear wheel
sensor information is sent to ABS ECM terminal No. 2, and is grounded
at terminal No. 1.


Now, anything else????
Reply With Quote Quick reply to this message
  #4  
Old 4th May 2004
boxman's Avatar
boxman boxman is offline
Saab on the Brain!
 
Join Date: Nov 2003                                                
Location: south west_UK
My Saabs: 9-3 SS Aero TTiD + 9-3 SV Aero
Posts: 7,970
Default

i think that the speedo gets its speed signal from the abs ecu not a wheel sensor but this is an asumption 'cus unless both front wheels are moving the speedo doesn't work

boxman
Reply With Quote Quick reply to this message
  #5  
Old 4th May 2004
bkrell's Avatar
bkrell bkrell is offline
Saab on the Brain!
 
Join Date: Sep 2003                                                
Location: Louisiana
My Saabs: gone: '01 9-5 2.3t, 1997 900 SE turbo
Posts: 9,423
Default

Right, but the ABS ECU gets it from the ABS/aka speed sensor. That info I posted is excerpted from the manual.

Edited due to stupidity.
Reply With Quote Quick reply to this message
  #6  
Old 4th May 2004
bkrell's Avatar
bkrell bkrell is offline
Saab on the Brain!
 
Join Date: Sep 2003                                                
Location: Louisiana
My Saabs: gone: '01 9-5 2.3t, 1997 900 SE turbo
Posts: 9,423
Default

Try this. That right view of the sensor is actually supposed to be showing it on the backside of the rotor.
Reply With Quote Quick reply to this message
  #7  
Old 4th May 2004
swdmus's Avatar
swdmus swdmus is offline
Senior Member
 
Join Date: Jun 2003                                                
Location: Central New York
My Saabs: 1991 900s and a 1994 900SE Turbo
Posts: 197
Default

Thanks guys that problems fixed I started the car up to day and the speedo worked fine I guess that sensor or something dryed out.
Reply With Quote Quick reply to this message
  #8  
Old 4th May 2004
bkrell's Avatar
bkrell bkrell is offline
Saab on the Brain!
 
Join Date: Sep 2003                                                
Location: Louisiana
My Saabs: gone: '01 9-5 2.3t, 1997 900 SE turbo
Posts: 9,423
Default

After all my hard work!!!!!!


Didn't I say something about rain????
Reply With Quote Quick reply to this message
  #9  
Old 4th May 2004
swdmus's Avatar
swdmus swdmus is offline
Senior Member
 
Join Date: Jun 2003                                                
Location: Central New York
My Saabs: 1991 900s and a 1994 900SE Turbo
Posts: 197
Default

Damn Rain I hope that all
Reply With Quote Quick reply to this message
  #10  
Old 8th March 2009
Saab Max's Avatar
Saab Max Saab Max is offline
Saab Crazy
 
Join Date: Mar 2008                                                
Location: NY
My Saabs: SAAB 900SE V6 2.5L / 9³SE 2.0/03 9-5Areo
Posts: 719
Default

Quote:
Originally Posted by bkrell
Oooops! Forgot this part!!!


ABS ECM receives wheel speed information from left front
wheel sensor at terminal No. 7, and is grounded at terminal No. 6.
Information from right front wheel sensor is received at terminal No.
5, and is grounded at terminal No. 3.
Left rear wheel sensor information is sent to ABS ECM
terminal No. 9, and is grounded at terminal No. 8. Right rear wheel
sensor information is sent to ABS ECM terminal No. 2, and is grounded
at terminal No. 1.


Now, anything else????
Im now confuse i thought it speed sensor came from the back left wheel.......? (2000 9-3) or am i wrong.......?
Reply With Quote Quick reply to this message
  #11  
Old 8th March 2009
earthworm's Avatar
earthworm earthworm is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: Goldsboro, PA
My Saabs: '96 900S, Automatic with 148K miles, blu
Posts: 21,251
Default

The speed(RPMs) is taken from all four wheels; only the left rear is used for the speedometer.
__________________
The earthworm
'96 900S, Automatic
Those who think in the past will have no future.
173K miles in the good ole USA
Reply With Quote Quick reply to this message
  #12  
Old 11th March 2009
Saab Max's Avatar
Saab Max Saab Max is offline
Saab Crazy
 
Join Date: Mar 2008                                                
Location: NY
My Saabs: SAAB 900SE V6 2.5L / 9³SE 2.0/03 9-5Areo
Posts: 719
Default

How do i tell if the ABS computer / pump........... is bad or sensors........ not sure what to do i have ABS light on also check engine
Reply With Quote Quick reply to this message
  #13  
Old 11th March 2009
earthworm's Avatar
earthworm earthworm is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: Goldsboro, PA
My Saabs: '96 900S, Automatic with 148K miles, blu
Posts: 21,251
Default

Codes ?....I do not know

Do check the electrical connectors at the ABS.

If you jam on the brakes, do you feel any pulses at the pedal ?
__________________
The earthworm
'96 900S, Automatic
Those who think in the past will have no future.
173K miles in the good ole USA
Reply With Quote Quick reply to this message
  #14  
Old 11th March 2009
Darren900's Avatar
Darren900 Darren900 is offline
Saab Lunatic
 
Join Date: Dec 2005                                                
Location: Chicagoland
My Saabs: 2000 9-3 T7 5-Speed 5-Door
Posts: 2,611
Default

Quote:
Originally Posted by Saab Max
How do i tell if the ABS computer / pump........... is bad or sensors........ not sure what to do i have ABS light on also check engine
The only certain way is with a tech2 reading the codes. If the car is post-1996, the CEL can be diagnosed with a generic reader.
Reply With Quote Quick reply to this message
  #15  
Old 11th March 2009
Saab Max's Avatar
Saab Max Saab Max is offline
Saab Crazy
 
Join Date: Mar 2008                                                
Location: NY
My Saabs: SAAB 900SE V6 2.5L / 9³SE 2.0/03 9-5Areo
Posts: 719
Default

Quote:
Originally Posted by earthworm
Codes ?....I do not know

Do check the electrical connectors at the ABS.

If you jam on the brakes, do you feel any pulses at the pedal ?
No pulses after the ABS light came on ( CEL and brake warning light also on)
on for about a week now
Reply With Quote Quick reply to this message
  #16  
Old 11th March 2009
Saab Max's Avatar
Saab Max Saab Max is offline
Saab Crazy
 
Join Date: Mar 2008                                                
Location: NY
My Saabs: SAAB 900SE V6 2.5L / 9³SE 2.0/03 9-5Areo
Posts: 719
Default

Quote:
Originally Posted by Darren900
The only certain way is with a tech2 reading the codes. If the car is post-1996, the CEL can be diagnosed with a generic reader.
Car is 2000 9-3.......
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:20 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.