No Start - SaabCentral Forums
* site search:  
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum

Go Back   SaabCentral Forums > Saab Classic 900, 1979-1993 & '94 Convertible > Saab Classic 900 Workshop
Saab Classic 900 Workshop Classic Saab 900 (1979-1993 & '94 Convertible) Technical Forum.

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 24-07-12
jt20 jt20 is offline
Junior Member
 
Join Date: Jul 2012                                                
Location: or
My Saabs: 91 900 na
Posts: 7
Default No Start

217k miles '91 non-turbo LH 2.4.2

Pump works and can pressurize the rail with a jumper between fuses.

Pump relay works - tested

.013V across pins #85 and #86 on the pump relay pins when cranking - not sufficient.

Ground signal is present @ pin #17 on the LH Control Unit harness.



It appears to be the control unit, Correct?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 24-07-12
peva's Avatar
peva peva is online now
Saab on the Brain!
 
Join Date: Feb 2004                                                
Location: West London & Wiltshire UK
My Saabs: '94 T16 Ruby 3dr, '93 T16 Ruby Vert.
Posts: 6,253
Default

Quote:
Originally Posted by jt20 View Post
217k miles '91 non-turbo LH 2.4.2

Pump works and can pressurize the rail with a jumper between fuses.

Pump relay works - tested

.013V across pins #85 and #86 on the pump relay pins when cranking - not sufficient.

Ground signal is present @ pin #17 on the LH Control Unit harness.



It appears to be the control unit, Correct?
Is there a spark? No spark = no fuel.
__________________

Reply With Quote Quick reply to this message
  #3  
Old 24-07-12
jt20 jt20 is offline
Junior Member
 
Join Date: Jul 2012                                                
Location: or
My Saabs: 91 900 na
Posts: 7
Default

Thank you. I will check the ignition system tomorrow.

What is the common failure by 200k miles? Coil, ignition control unit, hall sensor etc..?
Reply With Quote Quick reply to this message
  #4  
Old 24-07-12
peva's Avatar
peva peva is online now
Saab on the Brain!
 
Join Date: Feb 2004                                                
Location: West London & Wiltshire UK
My Saabs: '94 T16 Ruby 3dr, '93 T16 Ruby Vert.
Posts: 6,253
Default

Impossible to pick one above the other. They are all known to often go on forever. Saying that, the CPS (Crank Position Sensor), which is the hall sensor at the rear of the crankcase is known to fail occasionally.
__________________

Reply With Quote Quick reply to this message
  #5  
Old 28-07-12
jt20 jt20 is offline
Junior Member
 
Join Date: Jul 2012                                                
Location: or
My Saabs: 91 900 na
Posts: 7
Default

There is no spark. From a functioning, non-turbo '93 I swapped the EZK unit, amplifier and ECU - still no start and no spark.

What clever ideas do you folks have for rotating the crankshaft with the engine in place? It appears to be impossible after many attempts.


Following the FSM:


Knock sensor - good

power to EZK unit - yes

Power to amplifier - yes

power to coil - yes

coil resistance - good

amplifier switching - could never get 0.0V but the current amp had the same behavior as a known working amp

pulse signal from EZK - good

Hall sensor - can not check due to crank rotation.
Reply With Quote Quick reply to this message
  #6  
Old 28-07-12
Jim Mesthene Jim Mesthene is offline
Saab on the Brain!
 
Join Date: Feb 2006                                                
Location: New England
Posts: 9,458
Default

Quote:
Originally Posted by jt20 View Post


pulse signal from EZK - good
How did you determine that? It's not easy to measure. Is there a pulse at the coil?
Your symptoms match those of a failed Crankshaft Position Sensor. The tests described in the manual are always inconclusive, don't even bother with them. Look for a Primary ignition pulse while cranking.
__________________
Proudly marching from adolescence to senility, bypassing maturity.
Reply With Quote Quick reply to this message
  #7  
Old 28-07-12
jt20 jt20 is offline
Junior Member
 
Join Date: Jul 2012                                                
Location: or
My Saabs: 91 900 na
Posts: 7
Default

You are absolutely right. Without an oscilloscope, I had to default to a multimeter and the average was approx 2.8v

I see what you are saying.... but what is "Primary ignition pulse" Is that the 'quick test' by pulling a plug and grounding it?

I did that - no spark.

Is there a recommendation for testing the CPS, or just replace it...?
Reply With Quote Quick reply to this message
  #8  
Old 28-07-12
Jim Mesthene Jim Mesthene is offline
Saab on the Brain!
 
Join Date: Feb 2006                                                
Location: New England
Posts: 9,458
Default

See if the primary side of the Coil (the little wires) show pulsing voltage. The Hall Effect Transmitter (whether on the crankshaft or in the distributor) sends a signal. Try to find it after it has been amplified.
__________________
Proudly marching from adolescence to senility, bypassing maturity.
Reply With Quote Quick reply to this message
  #9  
Old 05-08-12
ragtopper1994 ragtopper1994 is offline
Junior Member
 
Join Date: Jan 2012                                                
Location: Rincon, GA
My Saabs: 1994 900s Convertible
Posts: 12
Default

I am having the same exact problem with my 94 vert, but adding to the mystery is that the wire harness that runs past the shifter burned up and shorted several wires. All of the wires have been replaced and rechecked. I have not checked for a pulse signal but will do this ASAP. There was a condenser wired between the coil and distributor but the wire is broken. Is this for radio noise reduction or is it required for normal engine operation?

Had my hand on the phone several times to call the junk yard to come and get it but I just can't seem to let it go.
Reply With Quote Quick reply to this message
  #10  
Old 05-08-12
16saabs 16saabs is offline
Saab on the Brain!
 
Join Date: Jan 2005                                                
Location: fakenham
My Saabs: 2x LPT convertible's, 1 x 900 SE
Posts: 5,594
Default

don't junkyard it sort it, but even if you want to get rid of it sell it someoe will give it a go, and give you more than a junk yard
__________________
22saabs
Reply With Quote Quick reply to this message
  #11  
Old 18-11-12
jt20 jt20 is offline
Junior Member
 
Join Date: Jul 2012                                                
Location: or
My Saabs: 91 900 na
Posts: 7
Default

Just an update.

Replacing the CPS via the tutorial on this site got the engine running again. There are other issues, but we solved the big one.

Thanks to all!
Reply With Quote Quick reply to this message
  #12  
Old 18-11-12
QuickOrange's Avatar
QuickOrange QuickOrange is offline
SaabNut!
 
Join Date: Apr 2011                                                
Location: Denver, CO
My Saabs: '92 900S, '93 900 Turbo Vert
Posts: 299
Default

Funny how that little sensor can cause so much trouble.
__________________
'93 Saab 900 Turbo Vert: New project...
'92 Saab 900 S: My first 900 and what a beauty
'90 Chevy 1500, Stepside: Ongoing project, future recipient of a 400HP LS2
'00 Kawasaki Ninja 500R
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine stalls alone or do not start. After some minutes start fine. dacer Saab NG900 & OG9-3 Workshop 3 16-02-13 01:28 AM
Refusal to start, then hard start, then finally starts - why? Kyle86 Saab NG900 & OG9-3 Workshop 1 08-09-10 12:36 PM
2001 9 3 Intermittently Won't Start. power, no ignition start. vpialums Saab NG900 & OG9-3 Workshop 4 28-09-08 02:32 PM
Cough & splutter on start up. Cuts out. Will/wont re-start. GONE FISHING Saab 9-5 Workshop 3 06-08-08 05:10 AM
No Start; Start - Weird Idle; No Start; Start - Runs Fine Black Beauty Saab Classic 900 Workshop 3 22-08-05 09:10 PM


All times are GMT -4. The time now is 05:38 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.