input speed sensor fixes? - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-3 SportSedan, Cabrio ('04+), Combi & 9-3X, 2003-2012 > 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop

9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 9-3 SportSedan, Convertible ('04+)/Combi & 9-3X , 2003 - 2012 Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th September 2011
gryffingirl gryffingirl is offline
Junior Member
 
Join Date: Nov 2009                                                
Location: Lincoln, NE
My Saabs: Silver '04 Saab 9-3t
Posts: 19
Default input speed sensor fixes?

So i couldnt come up with a good title lol. But anyway, I have a 2004 9-3 linear. I had my input speed sensor replaced in june of this year, and about a week later the radiator replaced along with that stupid faulty o-ring. Well, it's now september and my damn input speed sensor is out AGAIN!! The car just turned over 100k miles and i doubt its had the tranny fluid changed before, so it needs it done anyway. But when we (us saab owners) replace these speed sensors (typically due to faulty o-rings in the radiator) should we just drain and replace what tranny fluid comes out or do a flush? For those of you that don't know, these sensors generally go out due to water/coolant seeping into the transmission. My thought is that if i just drain the fluid, there will still be oil/possibly coolant in the valve bodies or in the tq converter area, am i thinking right? Thanks for any input.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 7th September 2011
gryffingirl gryffingirl is offline
Junior Member
 
Join Date: Nov 2009                                                
Location: Lincoln, NE
My Saabs: Silver '04 Saab 9-3t
Posts: 19
Default

Bump!!
Reply With Quote Quick reply to this message
  #3  
Old 8th September 2011
gryffingirl gryffingirl is offline
Junior Member
 
Join Date: Nov 2009                                                
Location: Lincoln, NE
My Saabs: Silver '04 Saab 9-3t
Posts: 19
Default

??????
Reply With Quote Quick reply to this message
  #4  
Old 13th September 2011
gryffingirl gryffingirl is offline
Junior Member
 
Join Date: Nov 2009                                                
Location: Lincoln, NE
My Saabs: Silver '04 Saab 9-3t
Posts: 19
Default

Thanks for all the replies.





























not!!!!!!!!!!
Reply With Quote Quick reply to this message
  #5  
Old 17th May 2012
JNRFLEXN JNRFLEXN is offline
Junior Member
 
Join Date: May 2012                                                
Location: Massachusetts
My Saabs: 2004 Saab 9-3 Linear
Posts: 21
Thumbs up

Quote:
Originally Posted by gryffingirl View Post
So i couldnt come up with a good title lol. But anyway, I have a 2004 9-3 linear. I had my input speed sensor replaced in june of this year, and about a week later the radiator replaced along with that stupid faulty o-ring. Well, it's now september and my damn input speed sensor is out AGAIN!! The car just turned over 100k miles and i doubt its had the tranny fluid changed before, so it needs it done anyway. But when we (us saab owners) replace these speed sensors (typically due to faulty o-rings in the radiator) should we just drain and replace what tranny fluid comes out or do a flush? For those of you that don't know, these sensors generally go out due to water/coolant seeping into the transmission. My thought is that if i just drain the fluid, there will still be oil/possibly coolant in the valve bodies or in the tq converter area, am i thinking right? Thanks for any input.
Hey good for you being on top of this, I have the same car with the same issues. I suggest you just drain the fluid that comes out and put in the new one, then two weeks later replace it again, repeat the process in 2 week intervals 3-4 times until the last fluid that comes out is clean.

I'm replacing my Input/Output sensors this weekend to see if I can get rid of the "Gearbox Malfunction SID" with code P0773.

If you do get back to this forum, I would like to know how your Saab is doing in regards to the coolant/trans fluid mix and any other codes.

Thanks!
Reply With Quote Quick reply to this message
  #6  
Old 17th May 2012
JonV JonV is offline
Saabista
 
Join Date: Mar 2004                                                
Location: Richmond, VA
My Saabs: 03 SE 5 Spd
Posts: 12,506
Default

When the fluid gets contaminated, there is a gelatinous build up inside the trans that draining will not remove.... described as a pinkish vasiline type substance...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Abs light, NO L rear speed input dzlsabe 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 0 17th February 2010 08:30 PM
2003 9-3 Input Speed Sensors brooksjs 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 0 1st February 2010 02:55 PM
VSS (Speed Sensor) Input location for installation of nav - 06 9-5 SportCombi tuttiface 9-5 Workshop 0 8th July 2009 06:45 PM
Input Turbine Speed Sensor jony51999 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 1 15th March 2007 02:44 PM
Taping the Speed Sensor for aftermarket Digital Speed Display DevilMan 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 8 10th June 2006 12:42 PM


All times are GMT -4. The time now is 09:02 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.