Sputtering and stalling - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd July 2011
Aedhan Aedhan is offline
Active Member
 
Join Date: Apr 2011                                                
Location: Michigan
My Saabs: 2001 Saab 9-5 SE
Posts: 39
Default Sputtering and stalling

Hey guys.. me again with my magical 2001 9-5SE 3.0t

This problem is relatively new and happened again tonight. When I started the car after work it fired right up but the RPMs would fluctuate, dropping real low like it was going to stall and then going back up again. I revved it up a bit and then started driving out of the lot. After a VERY short distance it stalled out completely.

I have had this problem before but usually after some cruising. The power just drops like crazy. What I find weird is there is no power, it doesn't really rev up but the boost gauge goes up. I was thinking maybe some sort of problem where cylinders were not firing or compression was lost. When it happens I usually stop, turn the car off and then turn it back on and it usually works just fine.

Once, it did it, no power and all that, sputtered, backfired and then ran fine. It threw a check engine light a couple times but not every time. The code was an O2 sensor high voltage and I believe once it gave an O2 sensor no activity or something along those lines. I have an exhaust leak and I think there is a good possibility that it is near one of the sensor, could that trigger it.

One more piece of info is that I know my front valve cover gasket is leaking oil into the spark plugs. (new gasket and grommets are on order to be replaced next week)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 22nd July 2011
carbonbased carbonbased is offline
Active Member
 
Join Date: Jun 2011                                                
Location: thompson pa
My Saabs: 1995 saab 900s 212,000 miles
Posts: 121
Default

i would check air filter cheapest thing, then mass air sensor, or throttle position sensor....its possible its one of those things but Ive never heard of a oxygen sensor doing that but i also don't own a newer Saab
Reply With Quote Quick reply to this message
  #3  
Old 23rd July 2011
Aedhan Aedhan is offline
Active Member
 
Join Date: Apr 2011                                                
Location: Michigan
My Saabs: 2001 Saab 9-5 SE
Posts: 39
Default

Quote:
Originally Posted by carbonbased View Post
i would check air filter cheapest thing, then mass air sensor, or throttle position sensor....its possible its one of those things but Ive never heard of a oxygen sensor doing that but i also don't own a newer Saab
Yeah, like I said, the O2 error is come and go, we figure it may be coincidence.

I will check the Air filter and and the MAF sensor when I get it apart next week. My old caddy had HUGE problems with the throttle position sensor because the head gaskets were bad and it blew oil back through and coated it. Hoping to replace the air box with a high flow intake, since I have heard a few good things about it.
Reply With Quote Quick reply to this message
  #4  
Old 23rd July 2011
carbonbased carbonbased is offline
Active Member
 
Join Date: Jun 2011                                                
Location: thompson pa
My Saabs: 1995 saab 900s 212,000 miles
Posts: 121
Default

yea i want a high flow intake too, my Buick was doing exactly what your saying stalling and everything and it was the air filter a ten min change lol...didn't have a problem since
Reply With Quote Quick reply to this message
  #5  
Old 23rd July 2011
Mendota's Avatar
Mendota Mendota is offline
Senior Member
 
Join Date: Jul 2010                                                
Location: MN
My Saabs: 2000 9-5 Aero wagon, 1999 9-3 convert
Posts: 157
Default

This just happened to me 2 weeks ago on a road trip. The car sputtered and lost power and died. I coasted into a parking lot and stopped, turned it off and restarted it just fine. As we pulled into our destination the car literally died. We coasted into a parking lot, again, and this time it would not start for anything. It ended up being the fuel pump. That was replaced but I am still getting some of the same symptoms of dipping RPMs and sputtering. I just replaced my spark plugs and that has helped a bit.

Next on the list is to replace my air filter, and if that doesn't do the trick then the DIC is next.

Good luck! These cars are awesome when they run properly!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stalling and sputtering saabrider C900 Workshop 3 7th July 2009 01:00 PM
sputtering 9-5 danlay 9-5 Workshop 17 19th September 2007 12:04 AM
HELP!!!! Sputtering..... babyjet 9000 Workshop 2 13th March 2006 09:54 PM
sputtering? williamsvr6 9-5 Performance, Mods & Tuning 2 3rd May 2004 10:47 AM
Sputtering SPG thebracko C900 Workshop 4 23rd February 2004 06:22 PM


All times are GMT -4. The time now is 12:17 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.