Heavy gas smell in oil. - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab C900, 1979-1993 & '94 Convertible (C=classic) > C900 Workshop

C900 Workshop Classic 900 (1979-1993 & '94 Convertible) Technical Forum.

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2004
83900 83900 is offline
New Member
 
Join Date: Jan 2004                                                
Location: savannah georgia
Posts: 1
Default Heavy gas smell in oil.

This is my first saab and im told it runs, but i havent cranked it yet. It was sitting for a few mounths at a shop around here. There is a very heavy gas smell in the oil, is there a sensor that could be causing this? Its a 83 900 turbo. I dont know much about import cars, all ive worked on is chevys and fords but i dont see how this can be that much different.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11th January 2004
REDTURBO84's Avatar
REDTURBO84 REDTURBO84 is offline
Saab Lunatic
 
Join Date: Aug 2002                                                
Location: no where
My Saabs: sold
Posts: 1,550
Default

Hi,Welcome to saabcentral,The gas smell is from fuel getting into the crank case one way or another ,get it out of there and start her up. I would start with a oil change and filter.Try to find a Bentley 8 valve manual. They are hard to find but offer the most complete easy to understand help..(Buy a $15.oo Haynes at a local parts store for now.) As far as being different than a Ford or Chevy,they are, But they are a enjoyable challence.The fuel system is tricky.My daily car of choice is a 84 turbo 900.Nice comfortable old car! Pat
Reply With Quote Quick reply to this message
  #3  
Old 11th January 2004
bohtak's Avatar
bohtak bohtak is offline
Saab Crazy
 
Join Date: Mar 2002                                                
Location: Kuala Lumpur, Malaysia
My Saabs: 82' C900
Posts: 573
Default

could be ur cars running to rich. if its a 83' model it should be a K-jet. try ajusting the fuel ratio.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:09 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.