code P0300 03' 9-3 - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-3 SportSedan, Cabrio ('04+), Combi & 9-3X, 2003-2012 > 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop

9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 9-3 SportSedan, Convertible ('04+)/Combi & 9-3X , 2003 - 2012 Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th October 2010
digimurda digimurda is offline
New Member
 
Join Date: Oct 2010                                                
Location: rhode island
My Saabs: 2003 saab 93
Posts: 1
Unhappy code P0300 03' 9-3

hi, i have a 2003 sab 9-3
i have my check engine light on and the code is p0300 (random misfire)
the car runs fine but when i step on the gas a little hard it shakes and studers, i've noticed it dies this when the turbo gauge needle is almost on the red part.
if it's the coils, how can i tell wich one is bad? or what is wrong?
please help, thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 27th October 2010
pacotaco's Avatar
pacotaco pacotaco is offline
Saab on the Brain!
 
Join Date: Apr 2009                                                
Location: mclean, VA
My Saabs: 04 93 arc espresso black
Posts: 6,381
Default

Quote:
Originally Posted by digimurda View Post
hi, i have a 2003 sab 9-3
i have my check engine light on and the code is p0300 (random misfire)
the car runs fine but when i step on the gas a little hard it shakes and studers, i've noticed it dies this when the turbo gauge needle is almost on the red part.
if it's the coils, how can i tell wich one is bad? or what is wrong?
please help, thanks.
well it sure seems like an ignition issue the easiest way to find out is to buy one new one and replace them one after the other till the issue is gone. you also might be able to look at the coil itself and you might see a spider web crack like this it should also be on the rubber piece of the coil too, i believe this can show that the coil is blown both of mine had that crack on them


__________________
i <3 backroads.

i rule your internet.
Reply With Quote Quick reply to this message
  #3  
Old 27th October 2010
aerojon's Avatar
aerojon aerojon is offline
Saab Lunatic
 
Join Date: Mar 2005                                                
Location: Cheshire.Uk
My Saabs: 04 9-3SS Hirsched Aero(Black)The Lady
Posts: 4,886
Default

Check for vacuum leaks.split pipes & alike..
__________________
I'd rather push my SAAB than drive a FORD or anything FRENCH..

ICM3 13sp system now with bluetooth audio streaming..
Reply With Quote Quick reply to this message
  #4  
Old 27th October 2010
Kooby Kooby is offline
Senior Member
 
Join Date: Nov 2007                                                
Location: Toronto
My Saabs: 2004 9³ Aero 6MT
Posts: 200
Default

Depending on the mileage of your car, you may want to replace all 4. They're approx $75 at rockauto and a very easy DIY repair. I bought 2 initially and did the dance of swapping them out. Found the shudder was gone but due to the age of the other coils, I was not getting full power, especially above 4K rpm. When I replaced all 4, all is good.

Hope this helps.
__________________
2004 9³ Aero 6MT
BSR Stage 1
Megan Springs
Reply With Quote Quick reply to this message
  #5  
Old 25th February 2013
death shot death shot is offline
Junior Member
 
Join Date: Aug 2012                                                
Location: Maryland
My Saabs: 2007 Saab 9-3 2.0T
Posts: 23
Default

2007 9-3 2.0T:

I thought I'd revive this thread as I'm having an issue with the same CEL code (p0300 with the occasional p0304). I've been having this issue where my car struggles to start (this morning it would not) when I try to cold start it in the morning. It feels like it is getting gas and trying to turn, but it just doesn't. I changed the spark plugs, which did not resolve the issue.

Once it struggles to start and eventually does, I let it idle for a few minutes and it runs fine. I can turn it off, then back on with no problem. I'm wondering what the problem could be. Ignition coils?

Last edited by death shot; 25th February 2013 at 07:48 AM.
Reply With Quote Quick reply to this message
  #6  
Old 25th February 2013
stefanb stefanb is offline
Senior Member
 
Join Date: Jan 2012                                                
Location: Knoxville, TN
My Saabs: 2003 9-3 Arc, 1988 900 Turbo
Posts: 229
Default

Those are random misfire codes. WIS says check fuel grade used, T8 software, spark plugs, ignition coils, injectors, cylinder compression, and fuel pressure.
Reply With Quote Quick reply to this message
  #7  
Old 31st December 2013
nateslaughter nateslaughter is offline
New Member
 
Join Date: Dec 2013                                                
Location: Boston
My Saabs: 2009 9-3 Sportcombi
Posts: 1
Default

Quote:
Originally Posted by death shot View Post
2007 9-3 2.0T:

I thought I'd revive this thread as I'm having an issue with the same CEL code (p0300 with the occasional p0304). I've been having this issue where my car struggles to start (this morning it would not) when I try to cold start it in the morning. It feels like it is getting gas and trying to turn, but it just doesn't. I changed the spark plugs, which did not resolve the issue.

Once it struggles to start and eventually does, I let it idle for a few minutes and it runs fine. I can turn it off, then back on with no problem. I'm wondering what the problem could be. Ignition coils?
Hello,
I'm having the exact same issue/CEL code with my 2009 9-3. Were you able to pinpoint/resolve the issue? Any guidance will help, thanks!
Reply With Quote Quick reply to this message
  #8  
Old 31st December 2013
Diggs's Avatar
Diggs Diggs is offline
Super Moderator
 
Join Date: Oct 2003                                                
Location: Shawnee, KS
My Saabs: 2003 9³SS Linear
Posts: 6,919
Default

Quote:
Originally Posted by nateslaughter View Post
Hello,
I'm having the exact same issue/CEL code with my 2009 9-3. Were you able to pinpoint/resolve the issue? Any guidance will help, thanks!
The cold start issue or just the codes? If it's the cold start issue you won't be happy. Lots of 2007-2008 2.0Ts are having this issue due to incorrect (or cast, we don't know) intake valves in the head being put in. Not a cheap fix. See the sticky at the top of this forum. There has been a case of a 2009 with this issue. How many miles on your car?
Reply With Quote Quick reply to this message
  #9  
Old 31st December 2013
death shot death shot is offline
Junior Member
 
Join Date: Aug 2012                                                
Location: Maryland
My Saabs: 2007 Saab 9-3 2.0T
Posts: 23
Default

Quote:
Originally Posted by nateslaughter View Post
Hello,
I'm having the exact same issue/CEL code with my 2009 9-3. Were you able to pinpoint/resolve the issue? Any guidance will help, thanks!
The gentleman above speaks truth. I did have the issue resolved by the best Saab mechanics in the mid-Atlantic: Sports Car Services in Delaware (My lord what a beautiful Saab showroom filled with classic Saabs!).

The issue isn't really Saab's fault, but basically it requires a valve job as the intake valves were not hardened correctly and start to feather. This causes compression to leak and in really cold weather, you may not be able to start the car.

To me it was worth the cost as I adore my car.

I highly, highly recommend Sports Car Services Saab.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:02 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.