Turbo Noise and Boost issue - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th July 2010
mickel1138's Avatar
mickel1138 mickel1138 is offline
SaabNut!
 
Join Date: Oct 2006                                                
Location: South Texas
My Saabs: 2003 9-5 Aero Wagon & 2004 9-3 Aero CV
Posts: 261
Default Turbo Noise and Boost issue

Hi,

Not too long ago I had a CEL of P1110 (if I remember correctly). The code most likely had to do with the Turbo Bypass Valve. So I ordered one. Ultimately it ended up being a vacuum line. (it disintegrated.)

After I replaced the vacuum line, by Turbo was working really well, super fast cycles, the boost needle was entering the first part of the red zone, it had power that I never knew it had before.

After some time it adjusted, and the cycles become slower and the needle at times barely touched the red area. I guessthe ECU figured things were back to normal.

Since I still had the new bypass valve, I decided to change it anyway. Took about 5 minutes, and I also tightened the turbo pipe a bit, it was a little loose (a 10mm nut).

It didn't get the power back I once had after replacing the vacuum line, it may cycle a little faster now. But just about when I almost hit maximum boost, about a little past the middle of the orange section, I hear a noise, it's like a hooting noise which goes away when the boost needle moves just a little bit further.

Now what is going on? Did I do something wrong with the valve, maybe I should but the old one back on? A leaking hose maybe? The airfilter is fairly new.

I'll see if I can make a video soon.
__________________
Mickel
http://saab.big-dutch.com/
Selfproclaimed member of: the Committee for the Liberation and Integration of Terrifying Organisms and their Rehabilitation Into Society.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 26th July 2010
Chris 9-5's Avatar
Chris 9-5 Chris 9-5 is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: SaabWorld
My Saabs: .
Posts: 22,211
Default

The hooting noise is a split rubber diaphram in the bosch dump valve:



The valve needs replacing.
__________________
I decline to grant to SAABCENTRAL.COM a non exclusive, royalty free, worldwide, perpetual license to reproduce, distribute, transmit, sublicense, create derivative works of, publicly display, publish and perform any materials and other information I submit to any public areas....
Reply With Quote Quick reply to this message
  #3  
Old 26th July 2010
mickel1138's Avatar
mickel1138 mickel1138 is offline
SaabNut!
 
Join Date: Oct 2006                                                
Location: South Texas
My Saabs: 2003 9-5 Aero Wagon & 2004 9-3 Aero CV
Posts: 261
Default

This is really stupid, it's supposed to be brand new. I got it from a box.

I guess it'll just put the old one back on.

I checked both valves with a vacuum pump, and blowing in them. Both appeared the working fine. The "new" one felt like it had a harder spring.

Thanks Chris.
__________________
Mickel
http://saab.big-dutch.com/
Selfproclaimed member of: the Committee for the Liberation and Integration of Terrifying Organisms and their Rehabilitation Into Society.
Reply With Quote Quick reply to this message
  #4  
Old 26th July 2010
Chris 9-5's Avatar
Chris 9-5 Chris 9-5 is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: SaabWorld
My Saabs: .
Posts: 22,211
Default

Is the noise still there with the old one on?
__________________
I decline to grant to SAABCENTRAL.COM a non exclusive, royalty free, worldwide, perpetual license to reproduce, distribute, transmit, sublicense, create derivative works of, publicly display, publish and perform any materials and other information I submit to any public areas....
Reply With Quote Quick reply to this message
  #5  
Old 26th July 2010
brewtide brewtide is offline
Saab Lunatic
 
Join Date: Jan 2004                                                
Location: Maine.
My Saabs: 2000 Aero wagon (5spd), 1999 9-5 (5spd)
Posts: 1,887
Default

Sometimes at the transition between vacuum and boost, my car will make a funny 'whale' sound. I've heard / know the blown out recirc valve noise, and it's different.

Is it just when you're riding the line between little boost and vacuum?

_ben
Reply With Quote Quick reply to this message
  #6  
Old 26th July 2010
mickel1138's Avatar
mickel1138 mickel1138 is offline
SaabNut!
 
Join Date: Oct 2006                                                
Location: South Texas
My Saabs: 2003 9-5 Aero Wagon & 2004 9-3 Aero CV
Posts: 261
Default

Brewtide, yes that sounds about right.

Chris, the NEW one is making the sound, I haven't put the old one back on, it didn't make any noise before as far as I could tell.
__________________
Mickel
http://saab.big-dutch.com/
Selfproclaimed member of: the Committee for the Liberation and Integration of Terrifying Organisms and their Rehabilitation Into Society.
Reply With Quote Quick reply to this message
  #7  
Old 26th July 2010
mickel1138's Avatar
mickel1138 mickel1138 is offline
SaabNut!
 
Join Date: Oct 2006                                                
Location: South Texas
My Saabs: 2003 9-5 Aero Wagon & 2004 9-3 Aero CV
Posts: 261
Default

On my way home I make a little video clip.

http://www.youtube.com/watch?v=GmXZ9mgOXgA

See if that helps...
__________________
Mickel
http://saab.big-dutch.com/
Selfproclaimed member of: the Committee for the Liberation and Integration of Terrifying Organisms and their Rehabilitation Into Society.
Reply With Quote Quick reply to this message
  #8  
Old 4th August 2010
mickel1138's Avatar
mickel1138 mickel1138 is offline
SaabNut!
 
Join Date: Oct 2006                                                
Location: South Texas
My Saabs: 2003 9-5 Aero Wagon & 2004 9-3 Aero CV
Posts: 261
Default

Replaced the Boost Valve, back to the old one, noise is gone!

Thanks everyone...
__________________
Mickel
http://saab.big-dutch.com/
Selfproclaimed member of: the Committee for the Liberation and Integration of Terrifying Organisms and their Rehabilitation Into Society.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:43 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.