9-5 windows/wipers/indicators problem - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th August 2009
hughesrob hughesrob is offline
New Member
 
Join Date: Aug 2009                                                
Location: London
My Saabs: 9-5
Posts: 4
Default 9-5 windows/wipers/indicators problem

A couple of days ago I opened the windows on my 2005 9-5 but was unable to close them when I wanted to. Without doing anything, a few minutes later, at the end of my journey, I was able to close them.

At the time there were no other symptoms.

I've just been out and part way through the journey my indicators stopped working. Also, the electric windows stopped working, likewise the wipers, front and back.

I've checked the fuses and there's nothing that I can detect, problem-wise.

Are there any other DIY steps that I can take to try to resolve this?

Many thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 15th August 2009
Chris 9-5's Avatar
Chris 9-5 Chris 9-5 is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: SaabWorld
My Saabs: .
Posts: 22,211
Default

How old / good is the car's battery?
__________________
I decline to grant to SAABCENTRAL.COM a non exclusive, royalty free, worldwide, perpetual license to reproduce, distribute, transmit, sublicense, create derivative works of, publicly display, publish and perform any materials and other information I submit to any public areas....
Reply With Quote Quick reply to this message
  #3  
Old 15th August 2009
red-aero's Avatar
red-aero red-aero is offline
Junior Member
 
Join Date: Apr 2006                                                
Location: kent
My Saabs: saab 9-5 aero bsr stg 1
Posts: 15
Default

the same thing happened to me a while back. first the indicators would not work, so i did a bit of research and found out they are controlled by the "dice" unit. i checked other functions that the "dice" controlled,eg wipers and windows, so i guessed it was this that was wrong. i took it to the dealers and told them what i believed was wrong and they told me that this doesnt usually give any problems. i got them to check it out and they confirmed it was this. it took a few days for one to arrive (apparently it is not a stock item) but once it did i had to pay around 270 for supply and fitting of a new unit. this was in 2006 on a 2000 aero. search the forum for "my indicators will not work"

Last edited by red-aero; 15th August 2009 at 06:21 PM. Reason: additional info
Reply With Quote Quick reply to this message
  #4  
Old 16th August 2009
hughesrob hughesrob is offline
New Member
 
Join Date: Aug 2009                                                
Location: London
My Saabs: 9-5
Posts: 4
Default

The battery is the one that came with the car when bought new in June 2005. To this point I'm not aware of any problems with it.

Various other electrical components do still work, e.g. music system, headlights, interior lights.

Could I perhaps simply swap in a battery from another car, temporarily, which presumably works, to check this out?
Reply With Quote Quick reply to this message
  #5  
Old 16th August 2009
hughesrob hughesrob is offline
New Member
 
Join Date: Aug 2009                                                
Location: London
My Saabs: 9-5
Posts: 4
Default

Thanks red-aero, I'll check that out.
Reply With Quote Quick reply to this message
  #6  
Old 30th August 2009
hughesrob hughesrob is offline
New Member
 
Join Date: Aug 2009                                                
Location: London
My Saabs: 9-5
Posts: 4
Angry

This has been resolved.

It seems as though the problem was caused by a faulty relay linked to the DICE.

Thank you Saab. 300 to replace a 16 component!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
electrical, problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:44 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.