Brake Light Failure Warning - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-5 Mk.I, 1998-2009 > 9-5 Workshop

9-5 Workshop 9-5 Workshop (1997 to 2010) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd February 2009
Chuck M'Gutsup Chuck M'Gutsup is offline
Active Member
 
Join Date: Aug 2004                                                
Location: Australia
My Saabs: 2002 SAAB 95 Aero
Posts: 49
Default Brake Light Failure Warning

HI there, I've had this problem a while now. Everytime I drive my car ranging from imediately after start up to 45 minutes later the "Brake Light Failure" warning pops up on th eSID.
None of the lights have gone. I assumed it is a bad connection. Any simple fix?
__________________
2000 95 Aero, Midnight.
+
1972 Sonett
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 22nd February 2009
mwistrom mwistrom is offline
Active Member
 
Join Date: Sep 2008                                                
Location: Seattle, WA
My Saabs: 2000 9-5 SE
Posts: 40
Default

Quote:
Originally Posted by Chuck M'Gutsup
HI there, I've had this problem a while now. Everytime I drive my car ranging from imediately after start up to 45 minutes later the "Brake Light Failure" warning pops up on th eSID.
None of the lights have gone. I assumed it is a bad connection. Any simple fix?
I've had the "Brake Light Failure" light come on randomly during driving my car. It seemed that it was never the side taillights, but there are about 6 (7 or 8??) individual lights in the central tail light at the top of the rear window. I opened it up and "jiggled" around all the lights to make sure the connections were good, and the message went away (for about a year. ). I need to do this again.

mark
Reply With Quote Quick reply to this message
  #3  
Old 22nd February 2009
Jssaab Jssaab is offline
Saab on the Brain!
 
Join Date: Aug 2006                                                
Location: DC Area, Maryland
My Saabs: 2000 9-5 320hp, 2003 Aero Hirsch "Clone"
Posts: 7,384
Default

Check the center mount light., it tends to get coroded due to the moisture that accumulates there in humid/window steaming conditions. You may need to pull the bulbs and clean it ( or buy a new one)
Reply With Quote Quick reply to this message
  #4  
Old 25th February 2009
lesenyap lesenyap is offline
SaabNut!
 
Join Date: Jul 2008                                                
Location: grays essex
My Saabs: 1998 95 se 20t (bmw worrier)
Posts: 274
Default

Quote:
Originally Posted by Chuck M'Gutsup
HI there, I've had this problem a while now. Everytime I drive my car ranging from imediately after start up to 45 minutes later the "Brake Light Failure" warning pops up on th eSID.
None of the lights have gone. I assumed it is a bad connection. Any simple fix?
mine used to do this one of the bulbs had an intermittent fault it used to stop working triggering the" bing bong sid calling message " and then start working again when i checked it ,till someone at work told me when i stopped it was not working then it started working again i changed the bulb, and no more bing bong , the lesson here is just because the bulbs look ok does not mean they are !!!
Reply With Quote Quick reply to this message
  #5  
Old 25th February 2009
jcjdavis1 jcjdavis1 is offline
Junior Member
 
Join Date: Oct 2008                                                
Location: Scotland
My Saabs: 1999 9-5 Estate 2.0t
Posts: 15
Default

Quote:
Originally Posted by Jssaab
Check the center mount light., it tends to get coroded due to the moisture that accumulates there in humid/window steaming conditions. You may need to pull the bulbs and clean it ( or buy a new one)
Hi I would do the high level brake light,I changed all the brake light bulbs and kept getting the message then changed the high level, problem solved. It is a bit expensive but easy to change. Jim
__________________
No longer a SAAB owner
Reply With Quote Quick reply to this message
  #6  
Old 26th February 2009
terryng terryng is offline
Active Member
 
Join Date: Dec 2006                                                
Location: Hong Kong
My Saabs: 2000 9-5 2.3SE Automatic Silver
Posts: 39
Default

I had the same warning weeks ago. It turned out that one of the small bulbs in the high mount break light was gone. The warning disappeared after replacing the faulty bulb.

Terry
__________________
Regards,
Terry
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:24 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.