high beam works low beam doesn't - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-3 SportSedan, Cabrio ('04+), Combi & 9-3X, 2003-2012 > 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop

9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 9-3 SportSedan, Convertible ('04+)/Combi & 9-3X , 2003 - 2012 Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th March 2008
lindave lindave is offline
New Member
 
Join Date: Sep 2007                                                
Location: Greensboro, NC
My Saabs: 05 9-3 Arc 2.0T
Posts: 4
Default high beam works low beam doesn't

I got the low beam failure SID, so changed the H7 55W halogen bulb. For the new bulb, it shines on high beam but not on low. I tried a 2nd bulb, and got same result so I'm guessing it's a wiring or harness short. Anybody have the same experience and how did you resolve?

TIA - (I searched forum but didn't quite find this answer, and I did use gloves when changing bulb). 2005 9-3 Arc 2.0T
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 28th March 2008
Frosty288's Avatar
Frosty288 Frosty288 is offline
Saab Lunatic
 
Join Date: Jul 2006                                                
Location: Williamsburg, Virginia
My Saabs: 2009 9-3 2.0T
Posts: 1,269
Default

A few months back I head headlights dropping like flies. First right low beam, then left low beam - at the end I was down to my left high beam, replacing the bulbs didn't help - went to the dealer and they said the 'filament' was broken (whatever that means) and they replaced them all. Havn't had a problem since. It was fixed under warranty.

If you still have warranty on your car, then you should just go to the dealer and they'll fix it for you.
Reply With Quote Quick reply to this message
  #3  
Old 3rd April 2008
lindave lindave is offline
New Member
 
Join Date: Sep 2007                                                
Location: Greensboro, NC
My Saabs: 05 9-3 Arc 2.0T
Posts: 4
Default

Thanks for your response, Frosty. The bulb I bought from NAPA must have been either the wrong one, (although it was labeled as H7 55W) or it's not standard issue enough for the SAAB. The dealer just put in one of their bulbs and problem resolved. I guess all bulbs are not created equal.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:18 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.