Random misfire - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab NG900, 1994-1998 and OG9-3, 1999-2002 & '03 Convertible (NG=new gen/OG=old gen) > NG900 & OG9-3 Workshop

NG900 & OG9-3 Workshop NG900 (1994 to 1998) & OG9-3 (1999-2002) & '03 Convertible Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st March 2008
white96850turbo white96850turbo is offline
SaabNut!
 
Join Date: Jul 2007                                                
Location: Milwaukee, Wisconsin
My Saabs: 1999 BMW 328is
Posts: 365
Default Random misfire

Hey all,

Well, today I finished my turbo install in my 1996 900se turbo (with the stock Garrett T25) and did some tune up things too (fuel filter, spark plugs, air filter, cabin filter, oil pan, GS motor and trans mounts, new oil, and fresh coolant).

But, after starting and letting the engine run for a good 15 minutes the car already set a code. I forgot the code number, but it was a random misfire (didnít say what cylinder) and it was bad enough for me to tell it was missing by the sound of the exhaust. I also tried to see if it was any different under load or through the RPM range and it wasnít any better. Also, after the turbo went and started blowing oil, the car sat until I had enough money (and after that, time and good weather) to do the rebuild. So the car sat about 6 months without running (bad idea....I know).

Any ideas on what could be the problem? I'm sure the gas is starting to turn bad, but I donít think it would be that bad. Right now I'm thinking that it's either the DI Cassette, or a plugged Fuel Injector, any good ways to test these with out spending tons of money?

Thanks,

~Brandon


EDIT: Just remembered that both O2's are bad (car was dumping oil into the exhaust) and it sounds like one cylinder isn't firing at all.....
__________________
-1996 Saab 900 SE Turbo
-1996 Volvo 850 Turbo

Last edited by white96850turbo; 21st March 2008 at 02:28 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 21st March 2008
white96850turbo white96850turbo is offline
SaabNut!
 
Join Date: Jul 2007                                                
Location: Milwaukee, Wisconsin
My Saabs: 1999 BMW 328is
Posts: 365
Default

Any ideas on what to do?
__________________
-1996 Saab 900 SE Turbo
-1996 Volvo 850 Turbo
Reply With Quote Quick reply to this message
  #3  
Old 21st March 2008
earthworm's Avatar
earthworm earthworm is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: Goldsboro, PA
My Saabs: '96 900S, Automatic with 148K miles, blu
Posts: 21,259
Default

The usual

compression
timing
condition of the ignition
It does sound as if seals and drying and breaking..
The gas may still be good - try some fuel stablizer or some ether..
Good luck
__________________
The earthworm
'96 900S, Automatic
Those who think in the past will have no future.
173K miles in the good ole USA
Reply With Quote Quick reply to this message
  #4  
Old 21st March 2008
jv_72_jv jv_72_jv is offline
Active Member
 
Join Date: Nov 2007                                                
Location: Denton, Texas
My Saabs: 90' 900s 3dr (sold), 88 900s 4dr
Posts: 109
Default

Quote:
Originally Posted by white96850turbo
Hey all,

Well, today I finished my turbo install in my 1996 900se turbo (with the stock Garrett T25) and did some tune up things too (fuel filter, spark plugs, air filter, cabin filter, oil pan, GS motor and trans mounts, new oil, and fresh coolant).

But, after starting and letting the engine run for a good 15 minutes the car already set a code. I forgot the code number, but it was a random misfire (didnít say what cylinder) and it was bad enough for me to tell it was missing by the sound of the exhaust. I also tried to see if it was any different under load or through the RPM range and it wasnít any better. Also, after the turbo went and started blowing oil, the car sat until I had enough money (and after that, time and good weather) to do the rebuild. So the car sat about 6 months without running (bad idea....I know).

Any ideas on what could be the problem? I'm sure the gas is starting to turn bad, but I donít think it would be that bad. Right now I'm thinking that it's either the DI Cassette, or a plugged Fuel Injector, any good ways to test these with out spending tons of money?

Thanks,

~Brandon


EDIT: Just remembered that both O2's are bad (car was dumping oil into the exhaust) and it sounds like one cylinder isn't firing at all.....
I suspect the DI cassette. You may have broken something when you removed it to change the spark plugs, but put a tank of fresh gas in it and see what happens
Reply With Quote Quick reply to this message
  #5  
Old 21st March 2008
white96850turbo white96850turbo is offline
SaabNut!
 
Join Date: Jul 2007                                                
Location: Milwaukee, Wisconsin
My Saabs: 1999 BMW 328is
Posts: 365
Default

Yea, I guess I'll be running down the basics and seeing whatís good and whatís not....The reason I donít think its the DI is because it was replace once already by the PO but I'm not sure when (car has 150,000 miles). How long do these DI last? Any sure fire way to check and see if thatís the problem with out spending $380 on a new one?
__________________
-1996 Saab 900 SE Turbo
-1996 Volvo 850 Turbo
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:50 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.