rough idle cold - SaabCentral Forums
* site search:  
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum

Go Back   SaabCentral Forums > Saab 9000 > Saab 9000 Workshop
Saab 9000 Workshop Saab 9000 (1985-1998) Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 25-10-07
saabfan9's Avatar
saabfan9 saabfan9 is offline
Saab Crazy
 
Join Date: Oct 2007                                                
Location: Chicago
My Saabs: 1973 99 EMS..2003 9-5 AERO..1984 900s..
Posts: 589
Default rough idle cold

hey guys my 96 aero at start up has a very rough idle after a minute she'll smooth out...no engine light and after seems to run just fine..any ideas? thanks for any help..chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 25-10-07
eerstkoffie eerstkoffie is offline
Active Member
 
Join Date: Sep 2007                                                
Location: Netherlands
My Saabs: 9000 CS 2.3 Automatic '92
Posts: 48
Default

i've had similar problems.
had a small leak in the plastic piece connected to the hose that is right out of the fuel tank.

changed my fuel filter. needs to be done after 150.000 k.

changed temp sensor on engine, its between the second and third fuel injector.

changed sparks for the proper NGK's.

DI module could be bad. they're on e-bay.
Reply With Quote Quick reply to this message
  #3  
Old 25-10-07
saabfan9's Avatar
saabfan9 saabfan9 is offline
Saab Crazy
 
Join Date: Oct 2007                                                
Location: Chicago
My Saabs: 1973 99 EMS..2003 9-5 AERO..1984 900s..
Posts: 589
Default

thank you eerst i will start doing a check on these things...did you get the problem dailed in? thanks for the input
Reply With Quote Quick reply to this message
  #4  
Old 25-10-07
eerstkoffie eerstkoffie is offline
Active Member
 
Join Date: Sep 2007                                                
Location: Netherlands
My Saabs: 9000 CS 2.3 Automatic '92
Posts: 48
Default

my swedish girlie runs well now, although cold idle is not perfect yet. but stable. guess they call that character, or charme ;-)

the temperature sensor between the injectors gave the most improvement.
thanks to someone here on the forum, i found it.
if the sensor is not connected, or broken, the engine gets the signal that it is warm all the time. so it wont start. but the sensor has like three steps, or measurements : warm / in betweem / cold. so it could cause your prob too.
Reply With Quote Quick reply to this message
  #5  
Old 27-10-07
saabfan9's Avatar
saabfan9 saabfan9 is offline
Saab Crazy
 
Join Date: Oct 2007                                                
Location: Chicago
My Saabs: 1973 99 EMS..2003 9-5 AERO..1984 900s..
Posts: 589
Default

what are some early signs of the di failing? i've owned several saabs but lucky enough not to have one fail...
Reply With Quote Quick reply to this message
  #6  
Old 27-10-07
eerstkoffie eerstkoffie is offline
Active Member
 
Join Date: Sep 2007                                                
Location: Netherlands
My Saabs: 9000 CS 2.3 Automatic '92
Posts: 48
Default

mine didn't fail till now. but i know from the cars history that it has been changed once. theu seem to last for around a 150.000 km.

i've heard you can notice it, cause it starts difficult, runs on 3 cilinders or rough.

maybe some more experienced forum readers could give this a more accurate follow up ?
Reply With Quote Quick reply to this message
  #7  
Old 27-10-07
SaabKen's Avatar
SaabKen SaabKen is offline
 
Join Date: Aug 2004                                                
Location: Vancouver, British Columbia, Canada
My Saabs: '06 9 2.0T SportCombi |'93 9K CSE (RIP)
Posts: 27,157
Default

Quote:
Originally Posted by eerstkoffie
the temperature sensor between the injectors gave the most improvement.
thanks to someone here on the forum, i found it.
if the sensor is not connected, or broken, the engine gets the signal that it is warm all the time. so it wont start. but the sensor has like three steps, or measurements : warm / in betweem / cold. so it could cause your prob too.
When mine was wonky, I'd always get the CEL (forget how many flashes). Indie just ripped out the old and plugged in a new one. Ta-da !

I find the fuel octane affects morning 1st cold start idle. With 87 I'd always get some minor stuttering stuttering stuttering (but never dies or anything), but with 89 or higher the smoothness will definitely be there with no roughness.
__________________
"Honesty is the best policy, but insanity is a better defense." - Steve Landesberg

Saab Club of Western Canada FB
Reply With Quote Quick reply to this message
  #8  
Old 27-10-07
eerstkoffie eerstkoffie is offline
Active Member
 
Join Date: Sep 2007                                                
Location: Netherlands
My Saabs: 9000 CS 2.3 Automatic '92
Posts: 48
Default

hmmm.... in this country, you can't get any less than octane 95.
but mine is still a lttle rough on cold idle.

it starts right a way, but, once it fires, i have to push the pedal just a little, otherwise it will stop. after like 10 secs running, i can leave the pedal alone. and she runs perfect from then.

character ? ;-)
Reply With Quote Quick reply to this message
  #9  
Old 27-10-07
saabfan9's Avatar
saabfan9 saabfan9 is offline
Saab Crazy
 
Join Date: Oct 2007                                                
Location: Chicago
My Saabs: 1973 99 EMS..2003 9-5 AERO..1984 900s..
Posts: 589
Default

she starts right up (no long crank)..but you can barely make it down the block very crabby and embarassing.. i would say aprox. 2-3 minutes she'll smooth out and not be a problem for the rest of the trip..no check engine light..never dies out just runs like **** ..idle control valve would give a die out at stops...thanks everyone for the help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:00 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.