'97 After replacing the battery radio won't work and SID won't display all the info - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab NG900, 1994-1998 and OG9-3, 1999-2002 & '03 Convertible (NG=new gen/OG=old gen) > NG900 & OG9-3 Workshop

NG900 & OG9-3 Workshop NG900 (1994 to 1998) & OG9-3 (1999-2002) & '03 Convertible Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th August 2007
Conrad Conrad is offline
New Member
 
Join Date: Aug 2007                                                
Location: SF
My Saabs: Saab 900 SE '97
Posts: 3
Default '97 After replacing the battery radio won't work and SID won't display all the info

Hello!

After replacing the car's battery the radio won't work and SID won't display all the info such as the temperature. I tried clearing the SID and reconnecting the battery without any result.
What can I do?

Best,
Conrad
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 29th August 2007
earthworm's Avatar
earthworm earthworm is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: Goldsboro, PA
My Saabs: '96 900S, Automatic with 148K miles, blu
Posts: 21,253
Default

Welcome to SaabCentral

http://www.saabcentral.com/forums/sh...ght=Radio+code
Please read post 5
This seems to happen about once a week.
The radio security info is in your manual.
I cannot explain the SID, it is sensitive to voltage changes, I believe..
__________________
The earthworm
'96 900S, Automatic
Those who think in the past will have no future.
173K miles in the good ole USA
Reply With Quote Quick reply to this message
  #3  
Old 29th August 2007
Conrad Conrad is offline
New Member
 
Join Date: Aug 2007                                                
Location: SF
My Saabs: Saab 900 SE '97
Posts: 3
Default I did punch in the code

Quote:
Originally Posted by earthworm
Welcome to SaabCentral

http://www.saabcentral.com/forums/sh...ght=Radio+code
Please read post 5
This seems to happen about once a week.
The radio security info is in your manual.
I cannot explain the SID, it is sensitive to voltage changes, I believe..
Well it's the first time it happened to me. I did punch in the correct code and I did read the manual. Any other ideas?
Reply With Quote Quick reply to this message
  #4  
Old 30th August 2007
97NG900tal 97NG900tal is offline
Active Member
 
Join Date: May 2005                                                
Location: Western Australia
My Saabs: '04 9-3 AERO
Posts: 100
Default

I;ve also had this problem.
Got a new battery just a couple of days ago, input radio code and all appears fine, apart from the fact that,on the lowest line of the SID it won't display "LOUD" when turning the radio on/ off.

Did you get any resolution at all?
Reply With Quote Quick reply to this message
  #5  
Old 2nd September 2007
Conrad Conrad is offline
New Member
 
Join Date: Aug 2007                                                
Location: SF
My Saabs: Saab 900 SE '97
Posts: 3
Default Nope

No resolution yet.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:52 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.