Im such and idiot!!!!! - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab NG900, 1994-1998 and OG9-3, 1999-2002 & '03 Convertible (NG=new gen/OG=old gen) > NG900 & OG9-3 Workshop

NG900 & OG9-3 Workshop NG900 (1994 to 1998) & OG9-3 (1999-2002) & '03 Convertible Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default Im such and idiot!!!!!

ANy and all help is welcomed and appreciated. Was working on car tonight bolting everything back together and missed an connected battery wrong!!! car want start i had it jumped adn drove it home but its definately in limpmode all everything is sluggish all the way down to windshield wipers,rpm is very low. I dont think the computer is fried or car wouldnt work at all am i correct. Starter is good or car wouldnt have taken the jump. battery light was on but also the brake light so not sure if alternator is fried. checked the 4 fuses right by battery and they are ok what could be the issue. please help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11th July 2012
'97 Saab SE Turbo's Avatar
'97 Saab SE Turbo '97 Saab SE Turbo is offline
Saabista
 
Join Date: Jun 2007                                                
Location: Columbus, Ohio
My Saabs: Black on black '97 Saab 3-door SE Turbo
Posts: 10,322
Default

Get an inexpensive voltmeter and check the alternator and battery. My guess is that the alternator is bad, and the battery ran down while running the car.

A fully-charged battery should be +12.5 VDC or slightly higher with the engine off. If the voltage is down 2 volts (you read +10,5 VDC), expect that it has one bad cell.

With the engine running, you should see +14.0 to +14.5 VDC. If the alternator is bad, you will only see the battery voltage.

If you have to change the alternator, do a search because it is one of the harder things to do on the car... Ron
Reply With Quote Quick reply to this message
  #3  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default

I've actually changed the alternator on car before its not 6mnths old....jusst wanna make sure that Ididnt do any damage to and of the computers,the check gear box light was on,and like Isaid EVERYTHING was sluggish
Reply With Quote Quick reply to this message
  #4  
Old 11th July 2012
'97 Saab SE Turbo's Avatar
'97 Saab SE Turbo '97 Saab SE Turbo is offline
Saabista
 
Join Date: Jun 2007                                                
Location: Columbus, Ohio
My Saabs: Black on black '97 Saab 3-door SE Turbo
Posts: 10,322
Default

It sounds like it's in limp mode... Ron
Reply With Quote Quick reply to this message
  #5  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default

So I guess my question is would the car be drivable if the ecu.was fried ?
Reply With Quote Quick reply to this message
  #6  
Old 11th July 2012
earthworm's Avatar
earthworm earthworm is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: Goldsboro, PA
My Saabs: '96 900S, Automatic with 148K miles, blu
Posts: 21,208
Default

Quote:
Originally Posted by fredric53 View Post
ANy and all help is welcomed and appreciated. Was working on car tonight bolting everything back together and missed an connected battery wrong!!! car want start i had it jumped adn drove it home but its definately in limpmode all everything is sluggish all the way down to windshield wipers,rpm is very low. I dont think the computer is fried or car wouldn't work at all am i correct. Starter is good or car wouldn't have taken the jump. battery light was on but also the brake light so not sure if alternator is fried. checked the 4 fuses right by battery and they are ok what could be the issue. please help
But it is impossible to mal-connect and tighten the battery cables!
But the "touch" is possible - with sparks flying all over....oooops...more than once......generally no damage except a deflated ego....

Probably both the alternator and the ECU and anything with a diode is fried..

Once I "messed up" with the Mercedes .. switched jumper cables....toasted the AC -generator....luckly, that was all !
__________________
The earthworm
'96 900S, Automatic
Those who think in the past will have no future.
173K miles in the good ole USA
Reply With Quote Quick reply to this message
  #7  
Old 11th July 2012
earthworm's Avatar
earthworm earthworm is offline
Saab Sage!
 
Join Date: Jun 2003                                                
Location: Goldsboro, PA
My Saabs: '96 900S, Automatic with 148K miles, blu
Posts: 21,208
Default

Quote:
Originally Posted by fredric53 View Post
So I guess my question is would the car be drivable if the ecu.was fried ?
no
Its time to visit your local friendly junque-yarde.
Good luck
Relate this story, you will find that you are not the only one...
__________________
The earthworm
'96 900S, Automatic
Those who think in the past will have no future.
173K miles in the good ole USA
Reply With Quote Quick reply to this message
  #8  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default

So I guess my question is would the car be drivable if the ecu.was fried ?
Reply With Quote Quick reply to this message
  #9  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default

Ok so if the car will start and drive with a jump then that means the ecu is ok am I correct the car is in limp mode tho.
Reply With Quote Quick reply to this message
  #10  
Old 11th July 2012
Nova Nova is offline
SaabNut!
 
Join Date: Sep 2009                                                
Location: Philadelphia 'burbs
My Saabs: '02 9-3 SE Hatchback, RIP
Posts: 276
Default

Your ECU is probably fine. My first instinct is to check the alternator (as a previous poster already said). If it needs a jump in order to start, you either have a bettery that won't take a charge, or the alternator is underperforming. The switched polarity may be to blame for that (damaging the voltage regulator). If you are a AAA member, they will come to you and do a complete battery/charging system test. Otherwise, check the voltage with a digital volt meter.
Reply With Quote Quick reply to this message
  #11  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default

Thanks nova and everyone else who chimed in,have the battery at work right now charging,will have the alternator check once I get home, will the car automatically come out of limpmode when everything checks out? Or is there some other step I need to do in order to reset it?
Reply With Quote Quick reply to this message
  #12  
Old 11th July 2012
Fox Fader's Avatar
Fox Fader Fox Fader is offline
Saab Crazy
 
Join Date: May 2012                                                
Location: Columbus, GA
My Saabs: '98 900SE Manual
Posts: 556
Default

Replace the main fuse or fusable link. It has most likely blown.
Reply With Quote Quick reply to this message
  #13  
Old 11th July 2012
BobSaabit BobSaabit is offline
Saab on the Brain!
 
Join Date: Oct 2009                                                
Location: Matchahusetts
My Saabs: '97 NG900 'vert; '03 OG 9 'vert
Posts: 9,455
Default

Quote:
Originally Posted by fredric53 View Post
Thanks nova and everyone else who chimed in,have the battery at work right now charging,will have the alternator check once I get home, will the car automatically come out of limpmode when everything checks out? Or is there some other step I need to do in order to reset it?
No, you need to reset limp home mode. Go to youtube and look for "reset limp home mode" & "saab".
Reply With Quote Quick reply to this message
  #14  
Old 11th July 2012
fredric53 fredric53 is offline
Active Member
 
Join Date: Sep 2010                                                
Location: usa
My Saabs: 2000 9-3 SE
Posts: 59
Default

Thank you guys sooooo much finally made it home with my recharged battery popped it under hood and she fired right up,and as for limpmode im guessing due to the low battery voltage it was recieving the car threw the limpmode signal. once it was seeing 13ish volts it was ok. Bad news alternator is shotout,but i just replaced it so its under warranty just gotta take a weekend to replace it. Bout to replace alternator and motors mounts and DIC cassette,but id like to thank all you saabnatics for your help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I am an idiot cleveland_saab 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 4 2nd September 2010 03:05 AM
Im an Idiot, and need some help olred1988 9000 Workshop 5 21st August 2009 08:05 AM
Idiot-I started my car without oil. skibum_infdl 9-5 Workshop 16 11th June 2007 04:35 PM
I am an idiot rowingdude The Lounge 49 10th July 2006 02:30 AM
okay.. I'm an idiot. G96nt NG900 & OG9-3 Workshop 8 19th January 2006 12:59 PM


All times are GMT -4. The time now is 01:14 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.