High Beam doesn't work after installing the HID Kit - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab 9-3 SportSedan, Cabrio ('04+), Combi & 9-3X, 2003-2012 > 9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop

9-3 Sedan, Cabrio ('04+)/Combi & 9-3X Workshop 9-3 SportSedan, Convertible ('04+)/Combi & 9-3X , 2003 - 2012 Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th July 2012
Junhyukbae Junhyukbae is offline
Active Member
 
Join Date: May 2009                                                
Location: United States Utah
My Saabs: 9-3 2.0T
Posts: 91
Default High Beam doesn't work after installing the HID Kit

I installed the aftermarket HID Kit(1 x 35w Apexcone HID Conversion

(APXHID35w), Bulb Type H7) on my 2007 9-3 2.0T

I only changed the projector light to hid light.

Oh, and the switch for the light too.

but not the day light and the highbeam light.

It was flickering so I updated the software to tech2.

After that the flickering was gone and the light was working perfect.

However, the problem was that if I want to use the day light I have to

put the switch to the left one time and if I want to use the day light and

the projector light(Low beam), I have to move the light switch 2times to

the left 2. This is ok because it means everything is working anyway.

However...the Highbeam doesn't work at all the light on my dashboard but

the highbeam is not working. Does anybody know this problem? I am reallly

in a hurry to fix it...because I have to pass the safety test and I can't

because of the highbeam issue...If there is anybody who can help I will

glad to appreciate it. Please help me...please......
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 5th July 2012
derekwilkinson's Avatar
derekwilkinson derekwilkinson is offline
Saab Lunatic
 
Join Date: Sep 2009                                                
Location: Houston
My Saabs: 2006 Saab 9-3 2.0T JZW Stg 3
Posts: 2,268
Default

tech 2 disables the high beams in your car because on the cars that do have xenon lights they use the same light and it just moves into a different lens. so no, you cannot use your high beams with tech 2 xenon enabled.

what you can try is getting error code eliminators and removing the tech2 change
__________________
2006 9-3 2.0T - JZW Stage 3

2007 BMW 335i Coupe - JB+ & Alpina TCU Flash
Reply With Quote Quick reply to this message
  #3  
Old 5th July 2012
Junhyukbae Junhyukbae is offline
Active Member
 
Join Date: May 2009                                                
Location: United States Utah
My Saabs: 9-3 2.0T
Posts: 91
Default hm..

so you mean first get the error code eliminator and remove the tech2 software? does this can fix the flickering problem too? because if i remove tech 2 software, it will start flickering...or maybe I should remove my current hid kit and change it to OEM Zenon light? How do you think...?But I do not know if it will work or not...because of the wiring capacity...
Reply With Quote Quick reply to this message
  #4  
Old 5th July 2012
billm0066 billm0066 is offline
Saab Lunatic
 
Join Date: Jan 2012                                                
Location: NC
My Saabs: 2010 9-3 aero 2008 9-3 sport
Posts: 1,056
Default

The error eliminators don't always work. I tried them on my Fusion and still got error messages. I used a Relay harness and used the turn on signal from the driving lights. Not sure if it will work on a Saab or not.
Reply With Quote Quick reply to this message
  #5  
Old 6th July 2012
Junhyukbae Junhyukbae is offline
Active Member
 
Join Date: May 2009                                                
Location: United States Utah
My Saabs: 9-3 2.0T
Posts: 91
Default Aftermarket HID Kit

Can anybody tell me how do you guys do if you guys have saab 9-3 2.0T 03~07 with halogen low beam, high beam, foglight?
I want to change it to HID lights! but I guess I have to downgrade the software from Tech2...can anybody please...tell me which product you guys used and how you guys made not to flick? please...tell me how...I couldn't pass the safety test today...and my car got pound......because of not renewing the registration plate...please any body help me...
Reply With Quote Quick reply to this message
  #6  
Old 6th July 2012
Junhyukbae Junhyukbae is offline
Active Member
 
Join Date: May 2009                                                
Location: United States Utah
My Saabs: 9-3 2.0T
Posts: 91
Default

I just figured out by my self...
I guess its because my halogen bulb was 55watt...and I bought 35watt hid kit...I think this is the reason why the light was flickering if i dont upgrade to tech2. hm...my guessing......
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver Side High Beam wont work 5speedracer 9-5 Workshop 9 16th December 2013 10:04 PM
Regular beam vs High beam Aerfally 9-5 Workshop 11 27th January 2008 08:31 PM
Dipped Beam to High beam broken? GPT27 C900 Workshop 2 8th June 2004 02:06 PM
high beam doesn't work after replacing bulb lowkey NG900 & OG9-3 Workshop 7 23rd October 2002 12:09 AM
High beam just work occasionally and intermittent dash light erro NG900 & OG9-3 Workshop 0 27th August 2002 09:16 AM


All times are GMT -4. The time now is 09:25 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.