SID problem after Stereo install. - SaabCentral Forums
*
Home Saab Pictures Saab Classifieds Saab Dealer Listings Saab Forum Saab Forum


Go Back   SaabCentral Forums > Saab NG900, 1994-1998 and OG9-3, 1999-2002 & '03 Convertible (NG=new gen/OG=old gen) > NG900 & OG9-3 Workshop

NG900 & OG9-3 Workshop NG900 (1994 to 1998) & OG9-3 (1999-2002) & '03 Convertible Technical Forum

SaabCentral.com is the premier Saab Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th January 2010
rcrain_83's Avatar
rcrain_83 rcrain_83 is offline
Active Member
 
Join Date: Jan 2010                                                
Location: San Diego CA
My Saabs: 1996 900se
Posts: 42
Unhappy SID problem after Stereo install.

sorry if im re-posting, but im new to the forum. I just purchased my first Saab. Its a 1996 900se and i instaled an Alpine head unit and type r front 6.5" in the front. the stereo works great, i bypassed the amp flipped the hot and acc etc. now my SID is flickering every 20 sec and my Black Panel button only blacks the SID, or when it does black the tach and fuel etc it wont come back on unless i turn off the car and re-start. any help fixing this would be awesone. thank you.
Reply With Quote Quick reply to this message
  #2  
Old 13th January 2010
Jeremy R.'s Avatar
Jeremy R. Jeremy R. is online now
Saab on the Brain!
 
Join Date: Oct 2002                                                
Location: Seattle, WA
My Saabs: 1997 900SE Talladega coupe
Posts: 6,011
Default

That's a pretty common problem, and easily fixed. Whatever wiring harness adapter you used has a wire that's putting 12 volts onto the SID bus. Take your radio out and unplug the wiring harness adapter. You'll see that the plug in the car has two gold-colored pins. Those are for the SID's data bus. Clip whatever wires are connected to those on your adapter and the SID should work fine. A lot of VW adapters have a loop of wire that connects to a bus pin that just needs to be clipped.
Reply With Quote Quick reply to this message
  #3  
Old 13th January 2010
rcrain_83's Avatar
rcrain_83 rcrain_83 is offline
Active Member
 
Join Date: Jan 2010                                                
Location: San Diego CA
My Saabs: 1996 900se
Posts: 42
Talking Thanx

AWESOME, thank you. Ill try it when i get home tonight.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the SaabCentral Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:51 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

top of page | sitemap | email us



copyright © 2003 - 2011 saabcentral.com, All rights reserved http://www.whiter.co.uk - valid xhtml - valid css
SaabCentral is an independently run website and is not affiliated in any way to Saab Automobile AB.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.