where is my odometer cable [Archive] - SaabCentral Forums

: where is my odometer cable


fringefighter
12th March 2006, 11:15 AM
My odometer doesn't work. My dash is apart. I swapped out the instument cluster. everything works except odometer. is it the small bicycle break looking thing? I connected it to that small gearbox thing down under, but where does it connect to after that. :nono;

Jim Mesthene
12th March 2006, 12:13 PM
The odometer drives internally off the speedometer.
The little cable and little box are part of the service reminder counter. It's only function is to count 30,000 miles, then turn on a light reminding you to do the 30k service. EPA demanded this light because there was no way to monitor O2 sensor function so it was to be replaced at 30k intervals. With LH came a check engine light, so the counter was discontinued.

fringefighter
12th March 2006, 12:22 PM
I connected the speedometer cable and it works fine. Then why doesnt the odometer work. I replaced the whole cluster. Thanks.:nono;

Tomarse
12th March 2006, 12:58 PM
I connected the speedometer cable and it works fine. Then why doesnt the odometer work. I replaced the whole cluster. Thanks.:nono;

One of the gears inside the speedo unit itself has probably broken so that the odo is no longer driven.
I have had to fix all the odo's on my 99's.

If you remove the speedo and then take the back off it should be fairly obvious. On all mine it has been the end cog which has split and been pushed off the end of the rod that goes through the centre. Hopefully it can be pushed back on and you could try gling of clipping it in place.

fringefighter
12th March 2006, 01:09 PM
I went to a junk yard to get another cluster. I will take the old one apart and try what you did. I take it this odometer is prone having this problem. When I bought the car the odometer wasn't working. I never had a problem going through inspection untill last week. The car always passed all inpection points. It looks like a mad max car I won't let it die.