check engine and oil lights [Archive] - SaabCentral Forums

: check engine and oil lights


alf
12th November 2002, 07:51 PM
hi,

i just bought a 92 Saab 9000 CS. Its a dream. Just a little mistake after my first comfortable 700 miles...

The control lights "check engine" and "check oil" are on.
But theirs no problem, i checked oil and the engine runs without any problems (i had to make my way home about 100 miles with the lights on). Is this an electrical problem that happens often?

any help would be greatly appreciated.

thanks a lot
alf :)

NickP
15th November 2002, 12:59 PM
Hi Alf,

By the sound of it the the oil level sensor is not working or there is a dodgy connection. Check all the wiring at the back of the engine bay. I found that part of the wiring loom was rubbing against the throttle housing, it had worn through the tape covering the cable by not through any cable (it would have it I had left it). Could be something similar with yours.

petercai
4th December 2002, 06:16 AM
Hi Alf,

Have you had your car checked? My 9000CS seems has the same problem now. The "check engine" light comes on after starting and never turn off! Would you pls tell me If you have any new information about your car concerning this metter, thanks a lot.

alf
25th January 2003, 08:48 AM
Hi Alf,

Have you had your car checked? My 9000CS seems has the same problem now. The "check engine" light comes on after starting and never turn off! Would you pls tell me If you have any new information about your car concerning this metter, thanks a lot.

My car is running without any trouble. Engine and oil level is ok. I think its a problem of bad connections between sensors and computer. The "check oil" warning is on since December but the oil level is ok. If i will have the time i will let check it, but there was no time yet...

Best wishes[/quote]