Possible clutch problem? [Archive] - SaabCentral Forums

: Possible clutch problem?


Gordy
12th October 2002, 11:16 PM
Hi, I'm currently driving a 96 Aero that was Abbottised during the summer. In the past couple of weeks I've noticed that my clutch pedal seems to be giving the sole of my foot a wee tap as I either engage or release it. There's no other problem, gear change is smooth and I haven't noticed any fluid drips. Does anyone recognise this as a precursor to a larger problem?

BillJ
13th October 2002, 09:29 AM
Welcome to SaabCentral, Gordy.

Sounds like wear in the clutch pedal or linkage. My '96 Aero does it too and the bite changes slightly when it goes "click", but I haven't found out yet which bit to replace to stop it. It does this sometimes while engaging the clutch and sometimes while disengaging.

It's been doing it now for almost as long as I've had the car, and it's had a new clutch in that time (precautionary measure when the engine and gearbox were out), so that's not it. I'm living with it and don't expect it to cause a major failure.

Gordy
14th October 2002, 12:06 PM
Thanks Bill, I can relax and start enjoying my car again. I'll get it looked at during my next service.

BillJ
14th October 2002, 12:49 PM
Sounds like a good idea. As a postscript, I've had the car for about 65K miles, and it's been doing that "click" thing for most of that, so you've probably got a few miles to go...

Alanb
14th October 2002, 04:12 PM
Yeah, I get the click as well. Nothing to worry about as far as I understand it.

Alanb