HID highbeam issue...what now ?? [Archive] - SaabCentral Forums

: HID highbeam issue...what now ??


thinkglad
30-09-10, 11:51 PM
On my way home tonight I noticed my drivers side headlight appeared to be brighter than the passenger side when I was behind a pickup at a stop light. Well I checked them against the garage door when I got home and it seems like the drivers side is stuck in the high-beam mode, when I select the high-beam the passenger side works correctly and matches the drivers side lamp, but when switched to low beam the drivers side stays on high-beam?? Any incite on this other than switching the lamps to see if its a bulb issue ??

gghh
01-10-10, 12:21 AM
the mechanic shutter inside the light is blocked.

thinkglad
01-10-10, 12:49 AM
Ok so this means disassemble of the mechinisim then...does it have to do with the self leveling system......sounds like this is going to be costly $$$:x

gghh
01-10-10, 12:53 AM
Try tapping at the housing, you cant disassemble the mechanism. No relation to the leveling. If it doesnt work, remove the light from the car and try to get access from the bulb opening.

thinkglad
01-10-10, 12:58 AM
Ok...Hmm...looks like that's going to be the project this weekend.....something must have broken off to get stuck in the shutter, or its just old perhaps, I will look online for an exploded diagram so I can better understand how this system operates I guess

Nathan 9⁵
01-10-10, 03:18 PM
Try this (http://www.youtube.com/watch?v=YI2yXfFkgtA) :cheesy:

thinkglad
02-10-10, 01:29 AM
Seems to be working after cycling it. Thanks for the tip!!:D