Steering wanders at speed [Archive] - SaabCentral Forums

: Steering wanders at speed


wonkyhamster
10th November 2008, 10:44 PM
The steering has always been light at speeds above 70mph. I decided to get under and check for slackness in the joints. Everything is tight but there is a knocking from the rack area when rocking the steering back and forth. Could there be issues internally at 140,000 miles? I can't think of anything else that would cause the vague steering. Front strut inserts are new. Any suggestions please?

Diosnoche
10th November 2008, 10:50 PM
did you check to see if the rack itself is bolted tight to the body?

Saabohème
10th November 2008, 10:50 PM
The inner tie rod drivers have bushings that deteriorate over time and GS now sells poly bushings to insert there. The outer tie rod ends are a wear/maintenance part and are due at your mileage if not yet replaced. Get the front end off the ground and grab each wheel by the top and bottom and push one side and pull the other. If play, check the ball joints too.

cadcamjim
10th November 2008, 10:50 PM
If you are rocking the wheel back and forth while the engine is off, the knocking would likely be there on a brand new car; it's a characteristic of most power rack and pinion setups. If you get the knocking with the engine running, you may have a problem. Some posters have stated that replacing the lower control arms (the only way to replace the ball-joints) makes a major difference, even though they couldn't necessarily detect that the old ones were loose while installed on the car.

wonkyhamster
11th November 2008, 09:51 PM
I held each of the tie rod ends and inner joints while the steering was rocked back and forth and could feel no play. I was expecting some movement due to the vehicle's mileage and was surprised to find them all tight! The lower control arms were renewed last year and that certainly made a big difference, but the high speed vagueness did not go away. This year the joints connecting the control arms to the radius arms were replaced with PU in an effort to improve the steering and the rack is mounted with a brace.

Yes; the knocking in the rack was with the engine off, so I won't worry anymore about that!

The car is very sensitive to wheel imbalance and it still has some vibration above 70mph. The vibration feedback feels like a hard knocking in the steering! Makes me think something is loose!

Darren900
12th November 2008, 10:45 AM
How are your spring dampers?

Owen423
12th November 2008, 12:35 PM
Sounds like the pressure regulator in the power steering pump is a bit wayward.

It is a divertor valve to stop the steering becoming light with higher engine speeds....

Owen

wonkyhamster
12th November 2008, 10:26 PM
Sounds like the pressure regulator in the power steering pump is a bit wayward.

It is a divertor valve to stop the steering becoming light with higher engine speeds....

Owen

Now that's an interesting thought!

wonkyhamster
12th November 2008, 10:30 PM
How are your spring dampers?

Strut inserts are new as I said. They were't too bad but I decided to renew them hoping the vibes would go away! Rear are original as far as I know but handling is good.

IanT54
12th November 2008, 10:56 PM
How about alignment? Checked that recently?

wonkyhamster
12th November 2008, 11:17 PM
How about alignment? Checked that recently?

Yes; I get it done about once a year. Last time was a year ago so maybe it's due!

IanT54
12th November 2008, 11:34 PM
It might be worth a try. I had what sounded like a soft knocking coming from the front end somewhere. It went away when I had the front end aligned.